2

So I've spent the past weekend trying to get this IBM Xeon server up and running. I also took this opportunity to try and get a bootable GPT/Grub2/BIOS setup going.

I am able to get the kernel booted, but I immediately get kernel panics. The kernel on the Gentoo LiveCD works fine. I've tried Gentoo and Vanilla sources and constantly see stack traces like the following. I've done a lot of searching and haven't been able to find anything useful.

Kernel Panic on Boot

I've tried disabling CPU Frequency scaling (based on some mailing lists that had a similar stack trace), but it gave me the same stack track on boot.

4
  • Have you tried other distributions? E.g. Debian? Apr 6 '14 at 23:55
  • Not yet. It's a full Gentoo VM I've been using for a while, so I don't really want to wipe it yet, plus the LiveCD works. I found the following bug: bugzilla.kernel.org/show_bug.cgi?id=61521 and will try the suggestions in there when I get home; might also take the kernel config from the gentoo live CD and just try using it.
    – djsumdog
    Apr 7 '14 at 3:23
  • You could try a Debian or Ubuntu Live CD. You don't need to wipe anything. Apr 7 '14 at 8:30
  • What URL did you use to download this distro (specifically)? Are you using the correct platform for Xeon?
    – slm
    Apr 7 '14 at 11:54
1

I found the following bug on the Kernel's bugzilla:

https://bugzilla.kernel.org/show_bug.cgi?id=61521

I ended up taking the kernel configuration from the Gentoo LiveCD and basing a new Kernel config off of that. I still got the stack trace, but I could now see a VFS error at the top. It was trying to detect /dev/sda4 as a UDF-fs partition.

I ended up adding a rootfstype=btrfs kernel parameter and it correctly mounted my root partition. I'm not sure if that was the original problem, but the stack traces seemed similar, so it's very possibly and just the ordering and screen resolution (I couldn't get the frame buffer to work) kept me from seeing that message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.