6

Is it possible to use agetty from the command line? I tried the command

sudo agetty -s 34800 tty8 linux

but it returns after a few seconds and tty8 is not open. Is it the expected behaviour?

Also, trying to start it in the background with

sudo agetty -s 34800 tty8 linux &> /dev/null &

returns immediately. Why?

1

I tried your line, I get the following in /var/log/secure (fedora19):

getty[12336]: bad speed: 34800

try this:

agetty -s 38400 -t 600 tty8 linux
  • Thank you, adding this timeout allows me to get a tty. But I am confused. Why did a timeout fix my problem? – Gradient Apr 7 '14 at 19:23
  • There is also the problem of starting this command in the background with & (added to the question) which still fails? – Gradient Apr 7 '14 at 19:25
  • No,you specified the wrong speed. The timeout can be left out of course. Use the right speed (38400) and the bachgrounding should work. Note that the "&" means that the job will be put into background and the shell returns immediately. – vasquez Apr 10 '14 at 9:47
  • Yes, with the right speed, it works. The backgrounding however does not. The job is stopped immediately. – Gradient Apr 12 '14 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.