2

I have strange trouble with Linux Mint 13 installation. I have Windows XP installed, I want to install Linux Mint as a second system (with dual boot), I've already done it multiple times on several machines, with exactly the same Mint version and even exactly the same installation media. But this time, I'm running into troubles: just after new Linux Mint installation is complete, I reboot, and I see the following:

error: no such partition
grub rescue>

I googled much and tried all of this: http://itsfoss.com/solve-error-partition-grub-rescue-ubuntu-linux/ and similar howto-s, nothing helped. I.e. I've reinstalled grub, no errors reported, but when I reboot, I got the same error again.

But then, I've noticed strange fact. I have two NTFS partitions: /dev/sda1 and /dev/sda5. My main Linux partition is on /dev/sda6, swap is /dev/sda7.

Then, in grub rescue prompt, I've entered ls, and the output is:

(hd0) (hd0,msdos5) (hd0,msdos1)

But, all of these partitions are actually NTFS! So that it doesn't see my ext4 partition completely. That's why it says "no such partition". Note that if I load via livecd and gun gparted, I see all of these partitions, everything looks fine. Of course I can mount it somewhere and chroot into it, it works.

But, GRUB doesn't see them.

What could be the trouble, and how to fix it?

UPD:

output of sfdisk -d /dev/sda:

mint@mint ~ $ sudo sfdisk -d /dev/sda
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
# partition table of /dev/sda
unit: sectors

/dev/sda1 : start=       63, size=102392577, Id= 7, bootable
/dev/sda2 : start=102392701, size=522749059, Id= 5
/dev/sda3 : start=        0, size=        0, Id= 0
/dev/sda4 : start=        0, size=        0, Id= 0
/dev/sda5 : start=102392703, size=324082017, Id= 7
/dev/sda6 : start=426475520, size=194473984, Id=83
/dev/sda7 : start=620951552, size=  4190208, Id=82

I'm not sure what exactly does that warning mean, but note that on another machine with the same configuration (WinXP + Linux Mint) I have very similar output of sfdisk, so that it shouldn't be a problem.

UPD2:

As @AvinashRaj suggested, I tried boot-repair, but it didn't help. Log: http://paste.ubuntu.com/7209498/

(it seems there was some problems, but at the end it reported Boot successfully repaired.)

And let me repeat that the GRUB just doesn't see my linux partitions (sda6 and sda7), for some reason.

http://paste.ubuntu.com/7209498/

  • What is the output of sfdisk -d /dev/sda? – Hauke Laging Apr 4 '14 at 22:14
  • I've updated my question. – Dmitry Frank Apr 4 '14 at 22:33
  • What's the status of all these partitions? Are you using them all? It would seem like the bootloader is "confused" and doesn't know which device to use to boot. – slm Apr 5 '14 at 1:34
  • Try boot-repair.If the problem not yet solved then post the contents of boot-repair log in your question. – Avinash Raj Apr 5 '14 at 2:10
  • @slm Is that relevant for ls? – Hauke Laging Apr 5 '14 at 7:34
0

It seems, the problem was that my HDD is too large for the BIOS in my laptop (320 GB), laptop is HP Compaq nw8240.

Firstly, I tried to completely reformat my HDD with gparted: I've created similar partition structure, installed Linux, GRUB doesn't work again, but now I got different error message: Error: out of disk.

After some googling I found that large HDD might cause this, so I've created little partition for /boot in the beginning of the HDD, reinstalled system using this partition, and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.