I went through the Arch installation yesterday, everything seemed to be going fine but when I ran startx it gave an error(in image below)- error message when I ran startx

Is it a problem with the graphics card driver? My laptop has Intel GL40 and I've installed the xf86-video-intel driver; is it the correct one?

  • What does the log file /var/log/Xorg.0.log say?
    – tak
    Apr 29, 2011 at 3:20

3 Answers 3


Have you installed xterm and twm? It doesn't appear so from that screenshot.

Make sure you install all of the Xorg base packages:

# pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils

From the Arch Beginners' Guide

  • @jasonwryan- Yes, I've already installed those packages but still it doesn't work
    – user3496
    Apr 29, 2011 at 4:02
  • 1
    The error message is pretty clear - neither package is found. Install them explicitly: # pacman -S xorg-twm xorg-xclock xterm
    – jasonwryan
    Apr 29, 2011 at 4:36
  • 2
    # pacman -S xorg-twm xorg-xclock xterm made it work. Thanks!
    – user3496
    Apr 30, 2011 at 6:14
  • Your link has broken -- now it is "Installation Guide" and there is no "Install X" section! Moreover the package xorg-server-utils no longer exists.
    – cat
    Aug 9, 2018 at 20:41
  • @cat Rolling release: answer was seven years ago: feel free to update...
    – jasonwryan
    Aug 9, 2018 at 20:44

To make sure that this is NOT the problem with X itself, you have to observe the below commands:

  1. X => This will start the bare X with mouse pointer. If it comes, your X is fine. Press alt+ctrl+backspace to get back to console again.

  2. Xorg -configure => Configure the xorg.conf for the underlying hardware.

  3. Xorg -config ~/xorg.conf.new => Start the X with this new config file.

Here ~ is your home directory.

This will start the X, with the configuration as per your ~/.xinitrc file. If you have the xterm, then create the ~/.xinitrc file as

$ cat ~/.xinitrc


Make this file executable.

  • 1
    In Arch, you start X with the command: startx - and Ctrl-Alt-Backspace is disabled by default... Also, he doesn't need an xorg.conf
    – jasonwryan
    Apr 29, 2011 at 9:26

Looks like you installed xorg but not a single window/desktop manager. Try this: pacman -S slim xfce4 xfce4-goodies this should install a whole bunch of stuff; normally that's annoying but in your case you want to 'catch up' your distro to all the libraries a normal desktop needs.

Once that's done, either enable slim in /etc/inittab (and disable any other session manager that's enabled, usually it's xdm by default), or I think you could also start slim as a service (you can do that in Debian, I don't have access to my Arch right now).

  • You don't need to install a display manager (Slim) or a desktop environment (XFCE) to run X...
    – jasonwryan
    Dec 1, 2011 at 17:37

You must log in to answer this question.