I have an ubuntu installation (amd64) on a SSD "A" and I copied the whole harddisk to another SSD "B" , (GPT, sda1=BIOS Boot partion , sda2 = ntfs (windows) sda2=ext4 (ubuntu), sda3 = linux swap)

I wrote the grub bootloader to the disk (on System with i7 970 CPU) with

grub-install /dev/sda

everything worked fine! On the i7 architecture I can now boot from the copied SSD "B".

But how can I use the copied SSD "B" on another architecture like the i5 LGA1150. Booting on this architecture does not work, the bootloader is not found somehow (black screen with one underline). Do I need to install the grub bootloader on the new architecture first, and will the copied ubuntu installation work then or is there still some inconsistencies?

UPDATE: Using Drive "B" : GPT Formated SSD

I have the following motherboard with the i5 CPU (does not work so far): http://www.asus.com/Motherboards/Z87PRO/

For the i7 I have the Asus P6T7 (boots successfully): http://www.asus.com/Motherboards/P6T7_WS_SuperComputer

Might that be the reason?

UPDATE2: So far, i disabled secure boot and turned on legacy boot in the bios of the Z87PRO, and changed the SSD "B" back to an MBR format, i installed grub on the i5 platform with the live cd (chroot method) and when trying to boot from "B" I could not boot into the bootloader, just black screen and returning to BIOS, any ideas?

My Boot Repair Dum is here, the correct one now> http://paste.ubuntu.com/7185224/

Solution: Finally I was able to boot the SSD "B" drive (architecture was no problem) but I still had a GPT partition table, which was a problem: I Changed the GPT to MBR (here: https://askubuntu.com/questions/84501/how-can-i-change-convert-a-ubuntu-mbr-drive-to-a-gpt-and-make-ubuntu-boot-from) then I reinstalled Grub from a Live CD Ubuntu 13.10 , (SSD "B" system is 13.04) from here: http://ubuntuforums.org/showthread.php?t=1581099 (with the chroot method!) rebooted, and finally the Grub worked! and also I could boot the kernels on the i5 architecture!

  • I imagine the problem is not so much with the different processors (amd64 should work on all but very specialised 64 bit desktop processors). More likely is that the BIOS on your LGA1150 machine doesn't support the GPT partition table that you have on the disk.
    – Graeme
    Mar 30 '14 at 17:58
  • 1
    As Graeme implies, the i5 and the i7 are not different architectures. It's possibly because the i7 is on a (newer) UEFI motherboard and the i5 is on a (older) BIOS style motherboard. en.wikipedia.org/wiki/UEFI UEFI and GPT go hand in hand.
    – goldilocks
    Mar 30 '14 at 18:25
  • 1
    The i5 board is certainly UEFI (technically UEFI replaces BIOS, although it seems many vendors are using the term 'UEFI BIOS' to sidestep the confusion). UEFI is required to support GPT, so changing the partition table definitely won't help. I would try disabling secure boot in the UEFI menu to see what happens.
    – Graeme
    Mar 30 '14 at 20:51
  • 1
    Hmm, the first line the Boot Repair Dump says Grub2 (v1.99) is installed in the MBR of /dev/sda, but the Drive/Partition Info says GUID Partition Table detected. This is a concern. Does the drive still boot in your i7 box?
    – Graeme
    Mar 31 '14 at 14:14
  • 1
    Ok, at least this is all MBR now! If it still doesn't work, I would go ahead and carry out the Recommended-Repair. I don't know if this will solve the issue, but it won't do any harm.
    – Graeme
    Mar 31 '14 at 15:30

If there is no specific reason you are using a GPT style disk beyond the fact that you have a UEFI system, you might want to try converting it to the regular MBR style. From wikipedia:

For backwards compatibility, most of the UEFI implementations also support booting from MBR-partitioned disks, through the Compatibility Support Module (CSM) which provides legacy BIOS compatibility.In that case, booting Linux on UEFI systems is the same as on legacy BIOS-based systems.

I.e., at this time using an MBR is bound to be more portable than GPT or the hybrid methods, etc. I have an Asus mobo w/ a UEFI AMI "BIOS" and the boot ssd (the only internal drive) uses MBR. I don't think I had to do anything special in the BIOS set-up, either. It just worked.

See here for how to convert GPT back to MBR. Since you can convert them back and forth (the only hassle being your grub setup), it is worth a try. Make sure that the issue really is that the i5 system does not support GPT first (if it is not UEFI, it doesn't).

  • I have the following motherboards (added in the post). might that be the problem, that it does not work in th i5 setup? :-), i think I ve created the BIOS Boot partition only for the i7 setup (where it works) and not for the i5 setup ( partitioned with gparted using gpt, no bios system partition) I think thats the problem?
    – Gabriel
    Mar 30 '14 at 20:25
  • I was under the impression you were trying the same drive ("B") on both machines. If not, you should clarify which drive is being used on which machine in the question.
    – goldilocks
    Mar 30 '14 at 20:54
  • added some information, to clarify in the information above :-)
    – Gabriel
    Mar 30 '14 at 21:04
  • Alright, I took "created the BIOS boot partition only for the i7 setup" to mean there was some other disk without this partition you were using on the i5. But they are the same disk after all. If Graeme's solution doesn't work, ditch the BIOS partition and switch the disk to MBR (unless you are also dual-booting windows). That's the easy trouble-free option and will work on both systems.
    – goldilocks
    Mar 30 '14 at 21:32
  • 1
    @Graeme : Specification for the P6T7 board from the link provided by the OP describes the BIOS as "16 Mb Flash ROM AMI BIOS, Green, PnP, DMI v2.0, Wfm2.0, ACPI v2.0a, SMBIOS v 2.4" -- nothing about UEFI, vs. the other one, which mentions UEFI explicitly. It looks like a pretty specialized thing. Anyway, I too doubt it is a GPT issue since it's the i5 UEFI board that doesn't work.
    – goldilocks
    Mar 31 '14 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.