0

Is it possible to start an xfreerdp session into Microsoft windows from a command-line only install of Linux?

The command I use from a full blown Linux install is this:

$ sudo xfreerdp /v:farm.company.com /d:company.com \
    /u:oshiro /p:oshiro_password /g:rds.company.com

This command works fine. However, when I run the same command from a command-line install of Linux, I get the following error message:

Warning xf_GetWindowProperty (client /X11/xf_window.c:178): Property 340 does not exist
  • Could that be indeed a warning, as it says, and irrelevant - while an unrelated error occurs elsewhere, with no log? – Volker Siegel Mar 30 '14 at 17:35
  • Why do you think the message is a problem? Is everything else working as expected? – Volker Siegel Mar 30 '14 at 17:36
  • It's a problem because a new window is not being generated on my computer which allows me to control a graphical RDS desktop session. – oshirowanen Mar 31 '14 at 8:32
  • Ok, but then the message probably has nothing to do with the problem; It's confusing us all like it confused you, because from the description now we think the message is relevant... – Volker Siegel Mar 31 '14 at 8:53
1

If you're just logged into a system that doesn't have a X desktop running then no you won't be able to make use of xfreerdp or any such application that requires the use of a GUI.

Remember that the X desktop is driving the videocard & monitor locally and is providing a basis (the X protocol) on which other graphical applications can also display GUIs through it as well. Without it any applications such as xfreerdp have no way to access the the display directly.

If you're familiar with the DOS/Windows model then think of trying to run a Windows application directly from DOS. This wouldn't be possible here either. There are libraries and services that Windows provides APIs to, which applications then utilize.

This is the tradeoff one makes when developing an application for a given environment vs. developing it as a standalone entity that can interact with a given system's hardware directly.

  • I installed xorg, doesn't that give me a local xdestkop? – oshirowanen Mar 31 '14 at 8:33
  • So you do have a graphical desktop then? From your Q it sounded as if you did not have one running. If you use the classic switches for xfreerdp does the problem persist? – slm Apr 1 '14 at 1:16
  • If xorg is a graphical desktop, then yes, I have that installed. I then type startx and still end up on the command line, but the resolution of the text changes to show smaller text on the command line. I installed it recently in the hope that it might help resolve this issue. When you say classical switches, do you mean - instead of /? – oshirowanen Apr 1 '14 at 12:15
  • @oshirowanen - yes the dashes instead of the slashes is the classic model for xfreerdp. I'm still not positive if you have an actual GUI desktop running. You're running something like GNOME or KDE, correct, and it's working? – slm Apr 1 '14 at 12:29
  • No i don't have GNOME or KDE installed, just the core xorg packages which is enough to generate dialog boxes from the command line using something like zenity. – oshirowanen Apr 1 '14 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.