2

I have just setup Elementary OS. I have two hard drives on my desktop and I can’t access either one of them via file manager. To be precise I have two partitions with data that I need to access; dev/sda4(on a 160GB hard drive) and dev/sdb1(on a 1 TB hard drive). I can see these drives using disk utility and gparted and they show them as unknown drives.

I have searched the internet for this problem and can’t seem to get anywhere. I have found that I may need to run the command “sudo blkid” to find the device UID so I can mount them with fstab. But whenever I run "sudo blkid" , I just get the UIDs of the ext4 partion(where I installed elementary) and the swap partition. I really need to access the data on those NTFS partitions. Is there any way I can mount those drives on Elementary?

2

Make sure you have some packages installed:

sudo apt-get install ntfsprogs ntfs-config

If you do have those and it still isn't working, try this as well:

sudo apt-get install ntfs-3g
1

As far as i know NTFS-read&write is standard installed/enabled on most Ubuntu versions nowadays. For linux-n00bs (like myself) this worked perfectly: How to Mount Partitions Automatically on Start Up in Ubuntu 14.04

  • Hello and welcome to the site! We recommend that users summarise links they post in their answers in order to avoid situations where a link becomes stale (e.g. the website it points to gets closed) and the answer is therefore rendered useless. If you include a summary in your post the answer may still be helpful even if the link is not valid any more. – Erathiel Apr 13 '15 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.