1

First of all I'm using Centos 6 server, putty and wordpress.org I followed the instructions from this link to set up vsftpd and ftp in centos server.

For the vsftpd.conf file, these were the changes I made:

anonymous_enable=NO
local_enable=YES
chroot_local_user=YES

All of them are uncommented. I then restarted the vsftpd service.

For iptables I enabled input and output for port 21.

After entering the user account name and password for ftp://domain.com, it seems like the server is not recognizing my username and password. They are the same credentials I have been using to log in to CentOS server.

Then I found something on Google about getsebool. It mentioned that ftp_home_directory is turned off and I needed to turn it on with setsebool -P

OK, now I am able to connect using ftp in putty, but not in the web browser or filezilla.

0
  1. Check your firewall logs. FTP actually uses ports other than 21 once the connection is established. 21 is only the control port.
  2. Try disabling selinux to see if the problem goes away. If it does you get to read up about configuring selinux more....
  3. The browser needs authentication information since anonymous is disabled. This means the URL needs the username and password embedded in it. Sadly SE won't let me post an example directly. Basically it is name plus @ plus pass followed by colon and the rest of the URL as normal.
0

There could be numerous amount of issues why you can't connect with the browser or filezilla but you need to eliminate issues in order to get it resolved.

I know that on filezilla, if you have vsftp on AWS you have to set the FTP transfer mode. Also with browsers, make sure you type in ftp://username@domain-addr it should prompt you with a password panel.

Maybe its your firewall and its bypassing putty ftp connection. Try to look at your vsftpd logs to see what else you can find.

0

You could try this command

sudo adduser -d /var/www/html -m myuser
sudo passwd myser
0

You likely need to allow tcp port 20 as well. Also you need to make sure you are using active mode. If the ftp connection tries to move to passive mode it will move to a high port and you don't have them open.

In filezilla you can modify the transfer mode by going to Site Manager->Create/edit site->Transfer Settings->Transfer mode you can force it to use active mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.