2

When I run, say, cp, I get output like the following:

# cp -v Foo Bar
âFooâ -> âBarâ

What's up with the weird â characters? Why is the shell doing this? It looks like some kind of strange encoding issue.

When I use PuTTY, I get â. When I log into the actual machine locally, I get ? in inverse-video. If I redirect stdout to a file, copy that to my Windows machine, and open it, I get some random combination of characters until I tell me text editor to pretend the file is UTF-8. And then I get propper open- and close-quotes.

1

It's an encoding issue.

Set your Putty character set translation to "UTF-8":

Window -> Translation -> Remote character set
1

To fix the PuTTY issue, change the Settings under Window -> Translation and select (or manually enter if not present) "utf-8"

Which shell are you using on the machine?

  • Just the default Bash shell. This is a default install of OpenSUSE, so I'm not sure why it doesn't work logging in locally. (PuTTY is another matter, obviously.) – MathematicalOrchid Mar 26 '14 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.