1

I am using Ubuntu 9.10 - the Karmic Koala - released in October 2009

I downloaded mysql-workbench-gpl-5.2.33b-1ubu1004-i386.deb from here

But when I run this package it show me following error:

Error: Dependency is not satisfiable: libatk1.0-0 (>= 1.29.3)

How can I install MySQL Workbench on Ubuntu.

  • It looks like 5.1.19 and 5.0.30 are available from the above link. – penguin359 Apr 28 '11 at 3:34
2

The simple answer is to either upgrade libatk or find an older version of MySQL Workbench. Sometimes there are newer packages in the backports repository, but I checked karmic-backports in Ubuntu's Package Repository and a newer version has not been backported. Ubuntu 10.04+ does have a newer version of libatk that's compatible with MySQL Workbench. You could try installing on 9.10 ignoring dependencies and hope it works anyways.

dpkg --ignore-depends=libatk1.0 -i mysql-workbench-gpl-5.2.33b-1ubu1004-i386.deb

The only other option is to download the source from 10.04 Maverick and recompile it on Karmic. Get the source from http://packages.ubuntu.com/source/maverick/atk1.0. You will need the .dsc, .diff.gz, and .tar.gz file from that page.

wget 'http://archive.ubuntu.com/ubuntu/pool/main/a/atk1.0/atk1.0_1.32.0-0ubuntu1.dsc'
wget 'http://archive.ubuntu.com/ubuntu/pool/main/a/atk1.0/atk1.0_1.32.0.orig.tar.gz'
wget 'http://archive.ubuntu.com/ubuntu/pool/main/a/atk1.0/atk1.0_1.32.0-0ubuntu1.diff.gz
sudo apt-get install dpkg-dev
dpkg-source -x atk1.0_1.32.0-0ubuntu1.dsc
cd atk1.0-1.32.0
dpkg-buildpackage

Once it's done building, you will have a number of .deb files in the parent directory. You will need to install any over what's already installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.