I want to begin exploring moving myself away from google apps, because it's expensive, and it looks like citadel has all of the groupware functions I need. So I am trying to install citadel-suite with:

apt-get install citadel-suite

But it returns:

citadel-suite: depends: citadel-mta but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Well, yes. It does require citadel-mta. That's half the point. So why is it not going to be installed? What broken packages do I have held? Why are they broken? Why are they held? I didn't hold them. Or break them, for that matter.

The problem with apt-get is that, for the 10 years I have been using it, it has, to borrow an Apple phrase, just worked. Now that it isn't, I'm rather at a loss. I did try the -f switch, but it didn't help. I haven't made any modifications to /etc/apt/sources.list, so I can't revert them. What should I try next?

  • I'd be glad to here about your experience with citadel. do you try the --fix-missing --fix-broken and other ?
    – Kiwy
    Mar 24, 2014 at 13:44
  • I suggest you study the situation with aptitude. Its dependency solver isn't as good as apt-get's, but since it's an interactive tool it makes inspecting the system's state much easier.
    – badp
    Mar 24, 2014 at 13:46
  • If I get it installed, I'll let you know. According to the feature list, it seems to do everything I need but two-factor authentication, and I can handle that through the VPN.
    – fastfinge
    Mar 24, 2014 at 13:46
  • @badp: Actually, it's dependency solver seems to be better. aptitude install citadel-suite proposes a solution. It wants to remove the virtual package mail-transport-agent. I didn't even know I had that installed, so removing it is probably fine. Why didn't apt just do that?
    – fastfinge
    Mar 24, 2014 at 13:47
  • @fastfinge Yeah, sometimes aptitude can get out of situations apt-get won't begin to touch, sometimes aptitude starts going North and suggesting you uninstall half of your system to fix a dependency with texlive documentation. :)
    – badp
    Mar 24, 2014 at 13:52

2 Answers 2


"... But it is not going to be installed" generally means that a serious dependency conflict will ensue if it's allowed to go on.

Try the following command:

aptitude why-not citadel-mta

why-not basically checks dependencies and returns the reasons it would have to not fill a particular dependency automatically.

In the case of my system at home:

shadur@leviathan:~$ aptitude why-not citadel-mta
i   exim4-daemon-light Conflicts mail-transport-agent
p   citadel-mta        Provides  mail-transport-agent

Apparently citadel-mta is a full-on MTA and will therefore replace whatever mail-transport-agent package you currently have installed. Explicitly telling it to install citadel-mta as well should be enough to break the deadlock.

NOTE: Doing so means your current mail server software will be replaced by the one that comes with citadel. Make very sure that that's what you want before you do this.

  • This is a testing server, being used to explore how well the citadel groupware server works as a gmail replacement, on a test domain, with no user data. So that's exactly what I want. Thanks!
    – fastfinge
    Mar 24, 2014 at 14:21

I found that installing with aptitude rather than synaptic or apt-get ended up working. aptitude is smarter and offered me resolution to the problem.

Edit: I did have to skip the first resolution suggested to get one that actually worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .