2

I recently installed Mint 16 alongside windows 8. I use the Internet through a proxy server in my campus.So after setting the proxy in the Network setting, I noticed that the Software center and the terminal cannot connect to the Internet.However, FireFox works fine and it has in its network settings to use the system proxy.So what is the problem? I can't install repositories using apt-get, help me please.

  • 2
    What is the exact error you're getting from apt-get? – terdon Mar 24 '14 at 0:23
4

Take a look at this Ubuntu Community Howto titled: AptGet/Howto, specifically this section, Setting up apt-get to use a http-proxy.

You typically set this environment variable like so:

$ export http_proxy=http://yourproxyaddress:proxyport

You can get the value for your proxy out of your browser if you don't know it already, since it's apparently working there. That should be enough to get your started, there are more details in those links if you need them.

1

I personally use cntlm on my CentOS virtual machine.

I use it as well under windows but I found it more stable under Linux, in Windows I have to restart it sometimes.

You can pass authentication to your Proxy using the configuration file under /etc/cntlm.conf.

After you still have to configure your OS to use the local cntlm as proxy like this:

  • gnome menu -> System -> Preferences -> Network Proxy
    1. Select: Manual proxy configuration
    2. Check the option: Use the same proxy for all protocols
    3. In HTTP Proxy: 127.0.0.1 and Port: 3128 (or the port your listening in your cntlm config)
  • in the root .bash_profile I added the following lines: export http_proxy="http://127.0.0.1:3128" export https_proxy="http://127.0.0.1:3128"

With this configuration my linux have no problems to connect through proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.