4

I have a 16 GB SanDisk Cruzer Blade Disk-on-key.

After a few days of use, it has become write-protected/read-only.

When I plug it in, you can see this in my Ubuntu's dmesg:

[  819.003359] usb 2-5: new high-speed USB device number 5 using ehci-pci
[  819.136249] usb 2-5: New USB device found, idVendor=0781, idProduct=5567
[  819.136257] usb 2-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  819.136261] usb 2-5: Product: Cruzer Blade
[  819.136265] usb 2-5: Manufacturer: SanDisk
[  819.136269] usb 2-5: SerialNumber: 4C530210071007116494
[  819.136891] usb-storage 2-5:1.0: USB Mass Storage device detected
[  819.137024] scsi8 : usb-storage 2-5:1.0
[  820.136696] scsi 8:0:0:0: Direct-Access     SanDisk  Cruzer Blade   2.01 PQ: 0 ANSI: 6
[  820.137150] sd 8:0:0:0: Attached scsi generic sg3 type 0
[  820.138497] sd 8:0:0:0: [sdc] 31266816 512-byte logical blocks: (16.0 GB/14.9 GiB)
[  820.142194] sd 8:0:0:0: [sdc] Write Protect is on
[  820.142204] sd 8:0:0:0: [sdc] Mode Sense: 43 00 80 00
[  820.144629] sd 8:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[  820.156667]  sdc: sdc1
[  820.159903] sd 8:0:0:0: [sdc] Attached SCSI disk

You can see that is says that write-protect is on.

I've already tried:

  • Looking for a read-only hardware switch
  • Using Gparted to format the drive. It says that the drive is read-only so it can't write to it
  • Using dd to overwrite the drive with 0s. It also can't open the device (/dev/sdc) for writing.
  • Pluging it in to a Windows 7. It too says it's read only

I did find this thread on Sandisk's forums. Does it mean that this has no solution? Must I just throw the Disk on Key after a mere days of use?

11

I've contacted SanDisk, and they've said it happened "beacuse the flash drive has detected a potential fault and became write-protected to prevent data loss. There is no method to fix this."

They've offered to replace it if I send it to them on my own expense.

They are, as it turns out, aware of this problem.

I, however, chose to switch to another company's disk-on-key.

Thank you.

  • Got the same issue with SanDisk Ultra USB 3.0 16GB, (idVendor=0781, idProduct=5581, SerialNumber: A20042D67501C440) – Linulin Mar 26 '15 at 17:08
  • 2
    Sandisk's Flash memories seem to be really, really faulty. A similar issue happened to me with a 64 GB Sandisk Micro SD card, only in this case the SD card did report the writes as successful but internally it would just discard them. I luckily found out because I moved a bunch of random downloaded crud into my SD card only to end up not seeing it at all, luckily because I didn't find out after losing a bunch of prized pictures due to a botched move operation. – RAKK Feb 25 '16 at 6:42
3

[ 820.142194] sd 8:0:0:0: [sdc] Write Protect is on

At least some flash storage devices (such as SD cards) do have internal write protect settings, including a permanent write protect bit. I first heard of this here, and don't know if it could apply to your device, but if you could not dd with root privileges to a USB stick then it would seem to be a hardware lock.

However, if this was done intentionally by, e.g., some Windows safety mechanism, it's unlikely that would use the permanent bit (if any).

Try:

sudo hdparm -r /dev/sdN

Where sdN is the correct device node. You will probably get:

/dev/sda:
readonly      =  1 (on)

Note that you may have to install hdparm first (search for a package with that in the name). You can try to change this setting with:

sudo hdparm -r0 /dev/sdN

This should set the "readonly" option to 0 (off). For more details consult man hdparm.

  • 1
    Thanks. I've tried using hdparm. Checking the write-protect bit does say that is is on. Setting it seems like it succeeded, but it is still write-protected and removing and re-plugging the disk-on-key makes that bit to return to 'on' – speller Mar 23 '14 at 21:48
  • Hmph. Well, the thing I certainly don't recommend bothering with is buying another one, lol. 19 pages of posts about this on Sandisk's own forum -- with no final solution except "it is probably broken except there's no way to prove this as Sandisk do not give their factory tools out to the public" probably == you got burned. :( – goldilocks Mar 23 '14 at 21:59
  • OTOH if you can return it for another one, Sandisk has probably made millions of these, and it could be some small percentage of them pass a QA check but then break within days. Your chances of having it happen twice in a row are probably really slim -- they do have a brand name to protect. – goldilocks Mar 23 '14 at 22:08
  • 2
    hdparm only controls the kernel read only setting for a drive, not any hardware setting it may have. – psusi Mar 24 '14 at 0:09
  • @psusi Foiled again. If it does involve hardware switches, this probably then requires Sandisk drivers which auto-installed via windows but are non-existent for linux, so looking for windows tools to reset this if possible is the best bet. Or it's just defective -- since we don't have a survey of all users of the device it is impossible to say whether it is a common problem or 1 in 100,000, etc. – goldilocks Mar 24 '14 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.