15

I have been using Arch Linux over a month now. I have used wifi-menu to connect to my Wifi Network. I run the command every time I start my laptop.

wifi-menu always gives this error when I try to connect:

Job for netctl@HelloWorld.service failed. See 'systemctl status netctl@HelloWorld.service' and 'journalctl -xn' for details.

The problem was that my interface was up every time I started. So I put the interface down using this:

ip link set down wlp2s0

wlp2s0 is my interface's name and HelloWorld is my Wifi Network's SSID.


This time, it didn't connect to the network regardless of putting the interface down. It gives me the same error described above.

This is the output of systemctl status netctl@HelloWorld.service:

netctl@HelloWorld.service - Networking for netctl profile HelloWorld
   Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static)
   Active: failed (Result: exit-code) since Mon 2014-03-24 02:32:35 IST; 2min 56s ago
     Docs: man:netctl.profile(5)
  Process: 8601 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
  Main PID: 8601 (code=exited, status=1/FAILURE)

Mar 24 02:32:34 lenovo network[8601]: Starting network profile 'HelloWorld'...
Mar 24 02:32:35 lenovo network[8601]: chmod: cannot access ‘/run/dhcpcd-wlp2s0.pid’: No such file or directory
Mar 24 02:32:35 lenovo network[8601]: Failed to bring the network up for profile 'HelloWorld'
Mar 24 02:32:35 lenovo systemd[1]: netctl@HelloWorld.service: main process exited, code=exited, status=1/FAILURE
Mar 24 02:32:35 lenovo systemd[1]: Failed to start Networking for netctl profile HelloWorld.
Mar 24 02:32:35 lenovo systemd[1]: Unit netctl@HelloWorld.service entered failed state.

journalctl -xn gives me this output:

Mar 24 02:38:05 lenovo kernel: brcmsmac bcma0:0: brcms_ops_bss_info_changed: qos enabled: false (implement)
Mar 24 02:38:05 lenovo kernel: cfg80211: Calling CRDA to update world regulatory domain
Mar 24 02:38:05 lenovo dhcpcd[256]: wlp2s0: carrier lost
Mar 24 02:38:05 lenovo dhcpcd[256]: wlp2s0: carrier acquired
Mar 24 02:38:05 lenovo dhcpcd[256]: wlp2s0: carrier lost
Mar 24 02:38:05 lenovo dhcpcd[256]: wlp2s0: waiting for carrier
Mar 24 02:38:05 lenovo network[8993]: Failed to bring the network up for profile 'HelloWorld'
Mar 24 02:38:05 lenovo systemd[1]: netctl@HelloWorld.service: main process exited, code=exited, status=1/FAILURE
Mar 24 02:38:05 lenovo systemd[1]: Failed to start Networking for netctl profile HelloWorld.
-- Subject: Unit netctl@HelloWorld.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit netctl@HelloWorld.service has failed.
-- 
-- The result is failed.
Mar 24 02:38:05 lenovo systemd[1]: Unit netctl@HelloWorld.service entered failed state.

systemctl gives the error that /run/dhcpcd-wlp2s0.pid doesn't exist, and it doesn't. Though a file named /run/dhcpcd.pid does exist.


This is the Network Controller output from lspci -k

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
    Subsystem: Broadcom Corporation Device 051b
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma

I have tried a couple of things from around the Internet but haven't found a solution.

Is there a way to fix this problem? Or can I just reset everything related to networking in Arch Linux so that I can just use wifi-menu to connect to the network again?

Thanks!

21

I had exactly the same problem. Have you killed the dhcpd?

I completely killed dhcpd:

$ sudo killall dhcpcd

After I disabled my wireless interface ($ ip link set down $ should work too):

$ sudo ifconfig wlp3s0 down

and my wifi-menu is working again.

  • I ran the commands but now it's telling me that the interface is controlled by netctl-auto. I couldn't find a way to disable that in the wiki. – Arjun Bajaj Mar 24 '14 at 21:55
  • The Error is: Interface 'wlp2s0' is controlled by netctl-auto A profile already exists for SSID 'HelloWorld' – Arjun Bajaj Mar 24 '14 at 21:55
  • no need to call "up" again? – アレックス Jul 5 '14 at 2:36
  • Lol.. Killing DHCPCD really nailed it. Thanks a bunch – Gorilla Moe Oct 31 '14 at 10:20
  • yeeeaahhh, thanks for this. @Alex, no need to call up again. – Мати Тернер Jan 15 '15 at 19:49
4

Why are you running wifi-menu each time you start? Unless you are constantly connecting to new wireless networks, you should simply use wifi-menu once to create a profile, then use netctl to automatically connect when you boot.

  • The changes I did because of this bug enabled the netctl-auto command to start wifi at boot. Now, it connects to the network at boot and I can use netctl-auto to reconnect. Thanks! :) – Arjun Bajaj Apr 12 '14 at 7:45
2

Probably a very late answer, but you can restart the dhcpcd, with the device down. And it should work.

$ ip link set dev wlp9s0b1 down

$ wifi-menu

if wifi-menu does not work, try installing networkmanager. and enabling it.

\# pacman -S networkmanager

\# systemctl enable NetworkManager.service

and restart.

0

This worked for me, I used netctl enable [PROFILE] to enable my wifi profile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.