1

Here's the link to the full instructions.

When I get to step 9, under the heading "9. Setup Client Config Files", it says:

Now we will configure the openVPN to work as client. Remember that we have already installed the openvpn package in client, and we have “ca.crt”, “vpnclient1.key”, vpnclient1.crt” in /etc/openvpn/

Copy the sample client.conf to /etc/openvpn.

$ sudo cp /usr/share/doc/openvpn/examples/sample-config-files/client.conf /etc/openvpn/

Edit the /etc/openvpn/client.conf.

...

Specify that this is openvpn client client

remote vpnserver 1194

ca ca.crt

cert vpnclient1.crt

key vpnclient1.key ...

Now start the OpenVPN in client

$ /etc/init.d/openvpn start * Starting virtual private network daemon(s)... * Autostarting VPN 'client'

$ ifconfig tun0 tun0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00

      inet addr:10.8.0.6  P-t-P:10.8.0.5  Mask:255.255.255.255

However, when I try to run that last command, I get the following error:

bash: /etc/init.d/openvpn: No such file or directory

I assumed that the script got subsumed by systemctl or something, so I then tried the next few:

# systemctl enable openvpn@.service 
# systemctl start openvpn@.service 

...which I stumbled on through tab completion. Can anyone shed any light on how to proceed?

0

If you are using Fedora, go to Fedora instructions. Similarly, don't use Fedora's instructions on Debian, and definitely don't follow instructions on random websites blindly. Distributions do change over time, configuration files are at different places (or the configuration is done in a completely different way).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.