1

I have a 16GB USB 3.0 thumb drive that has worked wonderfully up until two days ago...

When ever I plug it into a USB3.0 slot:

  • The light flickers indefinitely; Nautilus shows the Open/Eject popup as usual but when attempting to open in any file manager it hangs and after a while complains /dev/sdx no longer exists (even though lsblk says otherwise)
  • Trying to inspect with gparted produces a similar error, cannot find stat for /dev/sdx - it does not exist.
  • And a lot of scary dmesg output that I do not understand at all.

I can modify the device using fdisk. I have tried restoring the boot code and I have tried resetting the partition table and trying various different file systems.

Using the drive in a USB 2.0 slot works normally. Other USB 3.0 external drives and flash drives in the USB 3.0 slots work normally.

The device works on USB 3.0 ports in Windows and other Linux computers.

My main reason for posting is to try to learn and understand what is happening. Any advice is appreciated!

  • If the same drive works normally in a USB 2.0 port, it's not a disk format error. I'm guessing a hardware failure in the thumb drive's electronics? – alexis Mar 22 '14 at 10:26
  • I thought so too! But it works like a charm on other computers (USB3 & USB2) and it works in Windows 7 on the same computer... – beanaroo Mar 22 '14 at 12:51
  • hmm, that wasn't clear from your question. So it's only this computer-OS-drive combination that gives the problem. Then I'm guessing flaky/iffy drive (hardware or firmware) that many computers manage to handle, but you hit the jackpot. You could try reformatting (as thoroughly as possible) in case it helps. And have you tried all the different USB *ports on the same computer under Linux? – alexis Mar 22 '14 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.