20

nslookup does not come preinstalled in RHEL 7 Beta. I noticed even dig and host was not pre installed. I read couple of links which mentions nslookup is dead/deprecated, so is there an alternative for nslookup introduced in RHEL7 which comes preinstalled?

3
  • Have you tried "dig". I don't know if it's preinstalled by default. – periket2000 Mar 21 '14 at 10:50
  • 2
    What's wrong with installing bind-utils? RHEL7 simply doesn't have everything installed by default. – Warren Young Mar 22 '14 at 2:28
  • in official RHEL7 OpenStack image there is no nslookup/dig/host. You need to use "getent hosts" – Ivanov Jun 8 '15 at 7:46
32

Have you tried getent hosts?

[root@test ~]# getent hosts unix.stackexchange.com
198.252.206.140 unix.stackexchange.com

It's not give full details like nameserver,other resource record like other tools (dig) do, so if you want full details then you need to install bind-utils package. or just using ping to know ip

3

Actually the decision to obsolete nslookup has been reverted, at least in the nslookup provided by ISC. Source: https://kb.isc.org/article/AA-00496/0/BIND-9.9.0a3-Release-Notes.htm (Entry # 1700)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.