0

I have downloaded g2ipmsg from http://www.ipmsg.org/archive/g2ipmsg-0.9.6.tar.gz

While installing this package, it is causing some error.

 checking for G2IPMSG... configure: error: Package requirements (libgnomeui-2.0 >= 2.14
                gtk+-2.0 >= 2.4
                glib-2.0 >= 2.8) were not met:

    No package 'libgnomeui-2.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables G2IPMSG_CFLAGS
    and G2IPMSG_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

How to resolve this error please let me know.

1 Answer 1

2

Ensure that you have the package libgnomeui-2.0 mentionned into the error message correctly installed. Depending of your distribution, use apt-get or yum to install it. You may also need to install gtk+-2.0 and glib-2.0 (install first package and check the updated error message if any).

8
  • As he is running a configure to compile from source, he also needs to install the development counterpart of each of the package you mention. In Ubuntu, libgnomeui-dev, libgtk-3-dev and libglib2.0-dev. In Centos / RedHat, the packages will have -devel in the name.
    – Benoit
    Mar 21, 2014 at 9:17
  • can you give me the link where i can get and download pls Mar 21, 2014 at 9:42
  • There is a tool in Linux that allows you to download packages like this. It is apt-get for debian and yum for red hat. I see in another question of you that you are using CentOS which is Red Hat based. Then connect with root access rights and make yum install <package name> to install the mentioned packages.
    – Laurent C.
    Mar 21, 2014 at 9:48
  • 1
    I installed libgnomeui-devel by using yum install libgnomeui-devel it installed works fine. After installing i ran ./configure but it showing some error like No package 'libpanelapplet-2.0' found Mar 21, 2014 at 9:56
  • [root@localhost Admin]# yum install libglib2.0-devel Loaded plugins: fastestmirror, priorities, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: centos.aol.in * epel: mirrors.ispros.com.bd * extras: centos.aol.in * jpackage-generic: mirror.ibcp.fr * jpackage-generic-updates: mirror.ibcp.fr * updates: centos.aol.in Setting up Install Process No package libglib2.0-devel available. Error: Nothing to do Mar 21, 2014 at 10:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .