I've been trying to get Monodevelop up and running for almost a week now, first on my redhat and now on my fedora.

The debugger doesn't work, when trying to debug I get this error: enter image description here

I tried re-installing Monodevelop, but it's the same. I've looked at google, and the only thing I could find, was from three years ago, and it said it was a bug.

Here is the program I tried to run:

using System;

namespace ArteriumTarreDal
{
    class MainClass
    {
        public static void Main (string[] args)
        {
            Console.WriteLine ("Hello World!");
        }
    }
}

EDIT:

I'm running Fedora 20 x86_64 and just installed Monodevelop 4.0 through this instruction and repository: stackoverflow

For installation instructions with apt-get or yum, see: http://software.opensuse.org/download/package?project=home:tpokorra:mono&package=monodevelop-opt

Same problem with Monodevelop 4.0: enter image description here

Anyone got any clue what this is error is. And how to fix it?

EDIT: I got it working on Fedora 20 x86_64 KDE, but I still can't find how to fix it on Gnome.

EDIT: I just got this exact same issue on Debian 7 "KDE" in Monodevelop 5.4.

This is due to a recent gnome-terminal change. Recent gnome-terminal no longer accepts the --disable-factory argument.

Install the xterm package, then in a gnome-terminal session do the following:

$ unset GNOME_DESKTOP_SESSION_ID 
$ monodevelop

This will cause monodevelop to use xterm as its external terminal and all should be well.

  • 1
    This is the correct answer, not sure why it isn't marked so. – SpaceMonkey Jun 14 '14 at 15:43
  • This does work, however ugly haha. I'd recommend marking this as an acceptable answer as well. – cossacksman Nov 8 '15 at 8:35

It worked for me after I made a few changes to the stock install on CentOS 6.5 64-bit:

  • I added /opt/mono/bin to the PATH, and restarted my shell. The mono-opt package should arguably do this, but it does not.

  • In the freshly-created solution, right click the project (one step below the solution level) and select Options from the context menu. Go into Run > General and turn off Run on external console.

    You may not have to do this. I did because I ran MonoDevelop via an SSH-forwarded X11 session. It may not be necessary when running from Gnome Terminal or similar. Then again, if you run MonoDevelop by clicking an icon, it may be necessary if MonoDevelop can't open an external console window for some reason.

    Bottom line, this setting makes it run the program within the MonoDevelop environment, with output going to the Application Output tab in the UI. You probably can't use the program interactively with this setting.

    If you need to run a Mono console program interactively, best to do it straight from the terminal:

    $ mono foo/bin/Debug/foo.exe
    

    Here, the solution is called foo, but substitute your own name as necessary.

  • I didn't need to add /opt/mono/bin or modify my path at all. Just had to turn off Run on external console and blamo, it worked. – Daniel Jul 15 '17 at 4:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.