1

I bought a small Intel Atom machine (Intel atom D525) and I've installed Debian Wheezy on it.

After I install (successfully) the OS (via USB) the machine boots and after a couple of seconds I lose video link. Here is what happens:

https://www.youtube.com/watch?v=SbSvykUXIRk

What I already tried:

  • Using different system architecture (since d525 supports 32 bit aswell as 64 bit OS) : i386 , amd64
  • Using different installation supports: hd-media , dvd-1 cd-1
  • Modifying the grub parameters adding one of the following (as shown here) : nomodeset acpi=off GRUB_GFXMODE=vga=vesa GRUB_GFXMODE=1024x768

Here is how I set the various parameters:

https://www.dropbox.com/s/1v0muauk4resp05/2014-03-20%2019.36.26.jpg
https://www.dropbox.com/s/v5frd85u8c9kk77/2014-03-20%2019.35.02.jpg

Using live rescue mode:

I don't have X11 as I have not installed GUI.

Weird thing is that Debian 6 works just fine! What may be the issue?

  • I believe I see COM1 and COM2 serial ports on the back of that machine. Your best bet for debugging is to use a serial console. Connect to another computer using a null modem cable, then add console=/dev/ttyS0 to the boot line. I think the default is 9600-8-N-1. I think you can also add the rate to the end of that console line... its been a while. – derobert Mar 20 '14 at 21:44
  • BTW: I would guess that the kernel is activating the wrong port; perhaps its trying to use the HDMI port. If this is Intel video hardware (not sure what Atom uses), look at the i915 options. – derobert Mar 20 '14 at 22:17
  • I have already tried with i915.modeset=0 but with no result – Aaron Ullal Mar 21 '14 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.