1

I have a laptop with 8gb of RAM in two 4Gb slots, the processor is 64 bit compatible. However when I try to install 64 bit version of Linux (I tried, mint, arch, manjaro), it refuses to load the kernel and it will not boot up from a live cd or live usb. However, I can install 32 bit linux.

Another thing to note is that memtest86+ freezes after 0.01 seconds, so I thought maybe there could be a RAM problem, so I removed one stick. Memtest86+ still crashes although it is a different type of crash (the screen turns strange colors and computer reboots).

But here is the funny part, I can actually boot up the 64 bit distros from live media with only one slot of RAM, although it still would not actually let me install them, I can get around half way through installation process before it dies. Also I cannot boot into the previously installed 32 bit distro with only one stick of RAM...

O and one more thing, on my 32 bit manjaro install I tried installing a PAE compatible kernel which also would not boot..

So what is going on here? Is it dodgy RAM, or something else dodgy?

Thanks in advance.

Edit: this is one quarter of the output of

cat /proc/cpuinfo

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 37
model name  : Intel(R) Core(TM) i5 CPU       M 560  @ 2.67GHz
stepping    : 5
microcode   : 0x4
cpu MHz     : 1199.000
cache size  : 3072 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fdiv_bug    : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 11
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt aes lahf_lm ida arat dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips    : 5320.06
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
  • 1
    Did you grab the Itanium installation image? – Elliott Frisch Mar 20 '14 at 13:24
  • No? Is there one? I mean I have not heard of it.. – Orbit Mar 20 '14 at 13:39
  • Let me rephrase, which iso image(s) have you downloaded and tried to install (in 64-bit)? – Elliott Frisch Mar 20 '14 at 14:08
  • I have tried mint14 and mint16 64 bit versions, arch and manjaro 64 bit versions. I used the iso images available on their respective websites. (There is no option to choose itanium, unless I missed something?) – Orbit Mar 20 '14 at 14:58
  • you should try to see the exact output of dmesg when you boot on your working 32 bit linux... maybe your hardware is not what you think it is? – Olivier Dulac Mar 20 '14 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.