1

After a fresh install of Crunchbang Linux 11 on an Intel 486 powered machine I struggle with setting the display brightness which blasts at 100% … this is really, physically painful. My efforts to set up the xorg.config file usually results in booting in the most basic graphics mode. After all I've messed up the whole graphics department bad enough to the point of having to reinstall the whole thing.

01:00.0 VGA compatible controller: NVIDIA Corporation NV17GL [Quadro NVS] (rev a3) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation Device 015d
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Memory at fc200000 (32-bit, prefetchable) [size=512K]
        [virtual] Expansion ROM at fc000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0
        Kernel driver in use: nouveau

uname output:

3.2.0-4-486 #1 Debian 3.2.54-2 i686 GNU/Linux

As I work on a really old keyboard (PS/2 Plug) I don't have any Fn keys or such which usually work perfectly fine. 100% brightness all the time cause headache, pain in the eyes an no more ability to concentrate anymore.

Any idea or hint where did I took the turn into this dead end?


Update

As Karol Babioch pointed out, brightness is controlled via /sys/class/backlight/ – which is empty here. Any ideas?

2

Usually you can manipulate the brightness by directly interacting with the appropriate interface within /sys/class/backlight/. There are files representing the current brightness, which you can both read from and write to.

For example reading in the current brightness could look something like this:

[root@vpcs ~]# cat /sys/class/backlight/nv_backlight/brightness 
100

Setting it to something different:

[root@vpcs ~]# echo 20 > /sys/class/backlight/nv_backlight/brightness

Getting the maximum value:

[root@vpcs ~]# cat /sys/class/backlight/nv_backlight/max_brightness 
100

Depending upon the hardware and your kernel version, it might be that the interface is not registered correctly. The acpi_backlight kernel parameter might help in these cases, though this is just a reference for further investigations.

  • /sys/class/backlight/ is an empty directory here – erch Mar 19 '14 at 21:28
  • Have you played around with the acpi_backlight parameter already? At least in my case an ACPI bug is preventing it to work out of the box. I have to set it to vendor in order for the nouveau driver to register an interface. What driver are you using anyways? – Karol Babioch Mar 19 '14 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.