2

I am using Fedora 14 (Laughlin) with GNOME 2.32.0. I have gconf-editor installed. In gconf-editor apps->nautilus->preference confirm_trash is enabled i.e., checked, also in nautilus file browser, home folder, Edit->Preference->Behaviour "Ask before emptying the Trash or deleting files" is checked. But I am not getting any confirm box while deleting any file or folder. I googled for the solution but came up with nothing. Is this a Bug? Is it solvable? Thank you.

2

Moving a file to Trash does not delete the file - it simply stores it in a folder named "Trash" - you can retrieve files moved there so you don't get a prompt checking if you want to delete them when moving them there (as you are simply storing them somewhere else in the filesystem, not deleting them).

By selecting "Ask before emptying Trash or deleting files" you are setting a prompt when you actually delete them, either by emptying the trash, or by selecting the file and hitting ShiftDelete.

So, no - it's not a bug, it's a feature.

1
  • It is a "you don't have a choice" feature. If only there was an option to change the behaviour... – devnull Jun 30 '15 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.