4

Does anyone know how to install Mono and MonoDevelop on a Redhat 6.5 Workstation?

I've tried a number of different things but nothing has worked. I tried using git and building with make from the mono website but it didn't build.

2 Answers 2

8

Most of this comes from http://wiki.phonicuk.com/Installing-Mono-in-CentOS-5-x.ashx

1) Satisfy the dependencies before compiling mono

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -Uvh epel-release-6-8.noarch.rpm
yum install bison gettext glib2 freetype fontconfig libpng libpng-devel \
    libX11 libX11-devel glib2-devel libgdi* libexif glibc-devel urw-fonts \
    java unzip gcc gcc-c++ automake autoconf libtool make bzip2 wget

2) compile mono

cd ~
wget http://download.mono-project.com/sources/mono/mono-2.10.8.tar.gz
tar zxvf mono-2.10.8.tar.gz
cd mono-2.10.8
./configure --prefix=/usr/local
make

3) install mono

make install
1
  • I think this may be the first time directions on SO for a random series of linux commands actually worked on the first try. Oct 12, 2016 at 22:35
0

I found this link with a similar question:

stackoverflow

Quote:

For installation instructions with apt-get or yum, see: http://software.opensuse.org/download/package?project=home:tpokorra:mono&package=monodevelop-opt

I've used this repository on Fedora 20, and I will try it on my Redhat when get round to install the os on another computer

For install from this repo on Redhat use the Centos option.

For CentOS-6 run the following as root:

cd /etc/yum.repos.d/
wget http://download.opensuse.org/repositories/home:tpokorra:mono/CentOS_CentOS-6/home:tpokorra:mono.repo
yum install monodevelop-opt

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .