1

I am trying to compile vanilla Linux kernel 3.12.14 downloaded from kernel.org. When I try make gconfig, it says:

* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
*
make[1]: *** No rule to make target 'scripts/kconfig/.tmp_gtkcheck', needed by `scripts/kconfig/gconf.o'.  Stop.
make: *** [gconfig] Error 2

Now I checked and found my ubuntu has newest versions of libgtk2.0-0, libgtk2.0-bin, libglib2.0-0, and libglib2.0-bin and are manually installed. Cannot find libglade-2.0 whatsoever. I don't know how to go about that to make gconfig work properly.

>> sudo apt-get install libgtk2.0-dev libglib2.0-dev libglade2-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libglib2.0-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libglib2.0-0 libglib2.0-bin

Package libgtk2.0-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgtk2.0-dev' has no installation candidate
E: Package 'libglib2.0-dev' has no installation candidate
E: Unable to locate package libglade2-dev
4

You have missed developement packages.

They are libgtk2.0-dev, libglib2.0-dev. libglade2-dev.

Install them and try again.

Update

In my Ubuntu 12.04:

% cuonglm at ~
% apt-cache search libgtk2.0-dev
libgtk2.0-dev - development files for the GTK+ library
% cuonglm at ~
% apt-cache search libglib2.0-dev
libglib2.0-dev - Development files for the GLib library
% cuonglm at ~
% apt-cache search libglade2-dev
libglade2-dev - development files for libglade

For your errors, I think you have some broken in apt sources.list. Try adding correct sources list for 12.04 and run:

sudo apt-get update
sudo apt-get install libgtk2.0-dev libglib2.0-dev libglade2-dev

Or you can install from source, i.e this link is for libgtk2.0-dev.

  • First 2 packages you named are not installable on ubuntu 12.04, I mentioned 4 alternate packages it mentions and they are pre-installed as manually installed packages. libglade2-dev doesn't exist at all, for some reason. – JuliandotNut Mar 18 '14 at 9:39
  • Updated answer! – cuonglm Mar 18 '14 at 9:42
  • Updated question with status of these packages on my system. It is ubuntu 12.04 LTS 32-bit. – JuliandotNut Mar 18 '14 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.