25

My question is similar to this one, however the answers provided are not sufficient.

I'm a linux occasional user / learner, not having much background to understand what to do reading between the lines.

I've Ubuntu and Nautilus, in a mode that shows a left pane, without the appropriate content. At the moment a flat list, not a tree, shows personal folders, disk drives and network places (plus some bookmarks I managed to add). I assume I got the spatial view. I'd like to have a tree.

In the selected answer, the fix is to hit F9 to show the left pane. Not working. F9 just hides and shows this left pane I don't want. "View" menu also suggested is not even possible, since I've no menu displayed either.

The other suggestion to hit Alt-F2 to open a command prompt and then launch gconf-editor. Tried that, and got command not found. Also tried sudo gconf-editor in a terminal. Got the same result.

Did a little google work, but I mustn't express my problem correctly, results are similar to the linked question.

What's wrong with my configuration?

4
  • 1
    I'm pretty sure tree view in the left pane is not possible with nautilus. I suggest you try Thunar.
    – Seth
    Mar 17 '14 at 19:38
  • 1
    Yes, the best you can do is what @Braiam posted below, tree view within single folders.
    – terdon
    Mar 17 '14 at 19:42
  • This is how I did it based on Braiam answer: 1/ I installed dconf-editor 2/ in the tool I found the section org.gnome.nautilus.list-view, and here a check-box option use-tree-view. This allowed me to display a tree in the right pane. An acceptable work-around. I hope there is a better way, not requiring dconf-editor, directly from Nautilus. It seems I've Nautilus 3.10. Not sure.
    – mins
    Mar 17 '14 at 21:13
  • 1
    I'm a developer and from my point of view seems a very poor decision to get rid of the tree in the left panel of Nautilus. We use it a LOT. I wish I could answer your question better, but you will have to choose alternative file managers.
    – user74857
    Jul 8 '14 at 18:08
15

This is the most near that you can get of what you want, otherwise look for another file manager:

Look for 'Preferences', in the 'Views' tab, select "View new folders using: list view", then select the 'Display' tab, there will be a Checkbox that tells you 'Navigate folders in a tree', close Nautilus. Now open a folder and select list view, that way you will have a tree like behavior in the main panel.

enter image description here

If you don't like how it's shown then try with another file manager.

8
  • 6
    This is what the OP already has. Only your last sentence is relevant. Nautilus is so broken these days.
    – terdon
    Mar 17 '14 at 19:39
  • @terdon well, that's the most he can get out of Nautilus.
    – Braiam
    Mar 17 '14 at 19:42
  • 6
    True, I'll never understand why they crippled a perfectly decent file manager.
    – terdon
    Mar 17 '14 at 19:43
  • @terdon Indeed, Gnome (I think?) has slowly ruined Nautilus.
    – Seth
    Mar 17 '14 at 19:44
  • Thanks all. True this is in the left pane. Got it it is not possible with Nautilus. Now style would be worth to a try. However I've no check-box named "navigate..." (at least in the list opened with the arrow down button.
    – mins
    Mar 17 '14 at 19:49
13

Nautilus 3.5.4 and later

William Jon McCann removed this feature in version 3.5.4:

Use a list model instead of a tree model

It is the list view after all. Tree models don't work well on touch and it isn't consistent with the file chooser.

Nautilus 3.4.2

Select menu View then menu item Sidebar and then select Tree.

Toggle the sidebar between hidden/shown with F9

Nautilus 3.4.2

7
  • 4
    This appears to be for Thunar. Good example of an alternative to Nautilus though.
    – ssmy
    Mar 17 '14 at 20:32
  • Nautilus is exactly like this upload.wikimedia.org/wikipedia/commons/2/28/Nautilus-3.10.0.png for me. Assuming "Menu" is the button with arrow down icon, then no Tree option (Sidebar / F9 exists, but already tested).
    – mins
    Mar 17 '14 at 20:39
  • @ssmy I checked this on Nautilus 3.4.2, what is Thunar?
    – Zelda
    Mar 18 '14 at 5:02
  • 5
    Good answer, and culprit found. Quote - "It is the list view after all. Tree models don't work well on touch and it isn't consistent with the file chooser." Such contraversial decisions should always be left with user-customisable option. For me the left tree is invaluable, beacuse it is independently scrollable to the right pane, and so allows you to drag/drop between folders, and switch view between folders. Sep 11 '14 at 17:15
  • 3
    a feature loved by 99% peoples is removed for the sake of 1% peoples who use Nautilus on a touch screen! I'm exaggerating but, I hope he got a good reason while removing a feature
    – Hiep
    Mar 26 '17 at 0:56
2

On gnome-shell 3.28 (Ubuntu 18.04) this command works:

gsettings set org.gnome.nautilus.list-view use-tree-view true
1
  • 1
    I think that's the same as the accepted answer, and similarly does not give what OP asked for "tree view in left pane"
    – AdamS
    Aug 9 '18 at 16:58
0

The nautilus in ubuntu 14.04 does not have tree option in the left pane, however it works fine once you get used to it. Here is how to copy a file to another folder without using the copy command:

  1. Click the file and drag it to the folder or disk in the left pane
  2. That folder or disk will open in the right pane
  3. Continue to drag the file to the sub folder in the right pane
2
  • 4
    A lengthy drag operation is extremely error-prone; a tiny tremor on your index finger and files get dropped in the wrong place. Nov 30 '15 at 11:25
  • 2
    You'll notice how this solution stops being practical when you do not have to drag one file, but ten, or twenty, that you want to select one-by-one while inspecting the files in the source directory. Jan 7 '17 at 13:36
-3

Here is how to do this via dconf editor:

(switch-on "start-with-sidebar", restart nautilus)

through dconf

1
  • This does not seem to address the tree view issue.
    – Kusalananda
    Jun 28 '19 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.