6

I wrote a simple layout changing configuration for xmodmap (Caps/Ctrl swap, and such) and stored the config to $HOME/.Xmodmap. When I run xmodmap ~/.Xmodmap everything works fine, the layout is changed in every window.

But after some time, approx. 10 min, the layout is reset to default. This happens without my restarting the computer, closing the terminal where I called xmodmap, going to sleep-mode, whatever. Is there a process that could rewrite the layout automatically?

I am not sure if it is distribution-specific, but I am running Debian Wheeze with xfce4.

  • Do you have any crontabs running? Sounds like you might have set up something else a while ago. Have a look at crontab -l and the contents of your .bashrc file, you might be running another xmodmap command or something. – terdon Mar 16 '14 at 21:21
  • Can you tell if it's exactly every 10 minutes or only approximately? Install the acct package, wait for it to happen, and run lastcomm and look for invocations of xmodmap or xkb…. – Gilles 'SO- stop being evil' Mar 16 '14 at 23:40
  • Unfortunately, after reinstalling xfce I can no longer reproduce the behaviour. It suggests that the problem was in the session setting, altough the whole installation was fairly recent and I did very few modification to the session files. Anyway, thanks for your suggestions. Until I can reproduce the problem I would consider it solved. – Mr_B Mar 18 '14 at 8:06
2

https://lists.debian.org/debian-user/2011/04/msg01875.html

"I have the exact same symptoms on my box based on xfce 4, the culprit is a panel plugin xfce4-xkb-plugin 0.5.4.1-1, which I use to switch between languages. it resets the layout every 10 minutes.

from the README:

Known limitations and bugs

Currently if one sets any Xkb options, besides the grp: ones they will be lost the next time the plugin is started. Even more - only the first grp: option present in the running configuration will be stored in the config file and thus only it will be restored the next time the plugin is started. This will be resolved in future versions.

the README also mentions an undocumented (well...) config file option called

I edited the file which on my machine was found at: ~/.config/xfce4/panel/xkb-plugin-??.rc

and changed the 'never_modify_config' option to true. i then 'kill -9' the xfce4-panel process which respawned and reloaded the conf file.

the problem disappeared, I can manage keyboard layouts through the xfce4 settings/keyboard menu, and still switch languages using the xkb panel plugin."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.