1

I want to execute phpcs commands from phpcode using shell_exec function. During execution it gives error /usr/bin/php: relocation error: /usr/bin/php: symbol X509_free, version OPENSSL_1.0.0 not defined in file libcrypto.so.1.0.0 with link time reference. How can I solve this issue??

1 Answer 1

1

It seems that your libssl library is broken. Try running:

ldd /usr/lib/x86_64-linux-gnu/libssl.so
    linux-vdso.so.1 =>  (0x00007fffb3351000)
    libcrypto.so.1.0.0 => /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f28feaf1000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f28fe731000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f28fe52c000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f28fe315000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f28ff149000)

If your output shows file not found or point to an old version of libcrypto.so.1.0.0, you should reinstall openssl.

And if you compile php from source, please make sure you have --with-openssl option with correct place of libssl dir.

1
  • Congrats on 3k!
    – slm
    Mar 16, 2014 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .