3

I am on a minimal debian testing install. I've set up rxvt-unicode, herbstluftwm, and SLiM.

With my username, after SLiM logs me in, all of the urxvt terminal instances i start lack unicode support.

If I do sudo urxvt, then the new urxvt instance shows unicode characters in the terminal (as root).

This is a new install in a vm. Before I set up SLiM, I had unicode support as a user. at some point afterwards, I no longer saw the characters.

This issue seems very similar to this question, but I wasnt able to see any similar actions I could take.


relevant configs:

SLiM

default_path        /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
default_xserver     /usr/bin/X11/X
xserver_arguments   -nolisten tcp    
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm-C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue.net; exec /bin/login"    
xauth_path         /usr/bin/X11/xauth    
authfile           /var/run/slim.auth
numlock             on    
# hidecursor          false       
login_cmd           exec /bin/bash -login ~/.xinitrc %session
# login_cmd           exec /bin/bash -login /etc/X11/Xsession %session       
# sessionstart_cmd  some command
# sessionstop_cmd   some command        
# daemon    yes       
sessiondir            /usr/share/xsessions/    
screenshot_cmd      scrot ~/img/slim.png        
welcome_msg         Welcome to %host        
# session_msg         Session:         
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...        
default_user       seldon         
focus_password      yes        
auto_login          yes    
current_theme       debian-joy    
lockfile            /var/run/slim.lock
logfile             /var/log/slim.log

User env

SHELL=/bin/bash
TERM=rxvt-unicode-256color
XDG_SESSION_COOKIE=f71ffba1619e7393bb13421e5323c9ee-1394949532.816048-1558277790
WINDOWID=23068679
USER=seldon
MAIL=/var/mail/seldon
PATH=/home/seldon/bin:/usr/local/bin:/usr/bin:
      /bin:/usr/local/games:/usr/games:/home/seldon/bin
PWD=/home/seldon
LANG=en_US.utf8
COLORFGBG=default;default
SHLVL=1
HOME=/home/seldon
LS_OPTIONS=--color=auto --group-directories-first
LOGNAME=seldon
DISPLAY=:0.0
COLORTERM=urxvt
XAUTHORITY=/home/seldon/.Xauthority
_=/usr/bin/env

Root env

SHELL=/bin/bash
TERM=rxvt-unicode-256color
WINDOWID=20971527
USER=root
SUDO_USER=seldon
SUDO_UID=1000
USERNAME=root
MAIL=/var/mail/root
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/root/bin
PWD=/home/seldon
LANG=en_US.utf8
SHLVL=1
COLORFGBG=default;default
SUDO_COMMAND=/usr/bin/rxvt
HOME=/root
LS_OPTIONS=--color=auto --group-directories-first
LOGNAME=root
SUDO_GID=1000
DISPLAY=:0.0
COLORTERM=urxvt
XAUTHORITY=/home/seldon/.Xauthority
_=/usr/bin/env

Xresources

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!! Terminal Colors
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

! ... removed for brevity ...



!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!! URxvt Config 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

! buffer
URxvt*saveLines: 12000

! fonts
URxvt*font: xft:DejaVu Sans Mono:pixelsize=12:antialias=true:hinting=true
URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=12:antialias=true:hinting=true

! URxvt*font: xft:Bitstream Vera Sans Mono:pixelsize=12:antialias=true:hinting=true
! URxvt*boldFont: xft:Bitstream Vera Sans Mono:bold:pixelsize=12:antialias=true:hinting=true


! transparency
! URxvt*transparent: true
! URxvt*shading: 25

URxvt*depth: 32
URxvt.background: [75]#000000

! scrollbars
!    active - true (default) or false
URxvt*scrollBar: false

!    position - left=false (default) or right=true
URxvt*scrollBar_right: false

!    style - rxvt (default), plain, next, or xterm
URxvt*scrollstyle: rxvt

! borders
URxvt*borderless: true

xinitrc

#!/bin/bash

xrandr -s 8    
hsetroot -fill /home/seldon/img/olCTXdz.jpg &    

function wm() {    
    xrdb -load ~/.Xresources &    
    compton -cb -o0    
    exec $1 -c /home/seldon/.config/herbstluftwm/autostart    
}

[[ -z $1 ]] && wm herbstluftwm

wm $1
  • What's you distro? Display manager? – PersianGulf Mar 16 '14 at 6:31
  • I am on a minimal debian testing install (distro). I've set up rxvt-unicode (terminal), herbstluftwm (window manager), and SLiM (login mananger) – Hari Seldon Mar 16 '14 at 17:53
  • after doing some research I believe the issue is related to terminal behavior described here. Unfortunately the arch way of defining locale.conf doesnt seem to apply in debian, so I am now reviewing the equivalent debian docs. What still confuses me is that I have set LANG in my user's .bashrc (see above), and urxvt still seemed to be missing unicode support. – Hari Seldon Mar 16 '14 at 19:56
1

Ok... after reading TFM I found the answer, at least for Debian. According to the debian docs on locale, the default system wide locale is set in /etc/profile. After adding a line export LANG="en_US.utf8" all worked as it should.

The docs indicate that setting this value in /etc/default/locale should be enough, but it also mentions the /etc/profile as an alternative method.

For anyone else having similar issues:

  • I ran across this arch forum post which mentions a difference between setting the locale for your login terminal session, and your X session.
  • If urxvt does not have a unicode based locale set when it is run, then it defaults to not having unicode support. I found that here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.