I am my wits end. After happily using Fedora 12 for several years, I decided it was time to upgrade. So, I bought a new computer three weeks ago and have been trying to install Fedora 20 ever since, with always the same eventual result. The vendor installed Windows xp3 for me, and I am using it for this posting. I have no trouble at all with dual boot and the Windows installation, including Internet access, and my two laptops and Motorola Milestone 2 mobile phone are all ok with the 'net in my house, they are wireless, this computer is on a wired connection, to a BT Home Hub 3 router.

I have just tried, yet again, to install Fedora 20 from a DVD (full not live). At the "installation complete" message I ejected the DVD ready to re-boot, but the screen went blank and in the end I powered it down and turned it on again. I re-booted again from the screen because everything was very slow at first.

Then I encountered exactly the same problem as before, I try su then yum install emacs, which is my favourite editor, and got the result in the image. If Ihad left it running I would have got the usual streams (up to 200 or so) of the "trying other mirror" before it returns to the prompt.Screenshot of terminal

I have installation DVDs, from the same supplier, for F17 and F19, I have tried them all with the same result.

My problems all seem to be with the Internet in Fedora. However, using the default internet browser in the installed Fedora, most searches work after I try them twice in succession. And, of course, no Internet problems at all with the dual boot Windows on the same machine. I saved the image attached from Linux to Windows with no trouble, using the graphics listing application (is it "Dolphin" -- brain fuzzy) in Fedora.

Just to make it completely clear, the only problem I have with the Internet is in my newly installed Fedora 20: the Windows XP3 in its partition on the same computer is completely ok.

All that is different from my old F12 set up is a new computer and my Fedora installation. Please, what am I doing wrong? I hope that this is a recognised problem with a straightforward answer.

Added 16-03-2014

Thanks for the kind suggestions. I am now getting the error "Cannot retrieve metalink for repository: fedora/20/i386. Please verify its path and try again". A web search shows this to be very common, with as many different answers as questions. None of them, those I can make sense of anyway, work for me.

What is really needed is a diagnostic procedure that will lead to the underlying fault, and to a solution. Where can I find such a procedure, does it exist?

  • 2
    My problems all seem to be with the Internet. Yeah, although the next sentence is pretty confusing in this regard. Can you access the internet in any way?
    – goldilocks
    Mar 15, 2014 at 19:37
  • 1
    If internet isn't working them YUM will never succeed. Get the internet working 1st and other problems will just fall away.
    – slm
    Mar 15, 2014 at 21:35
  • Thank you, sim, that makes good sense, but how do I tackle it when I think I have already done everything correctly as far as I can tell, apart from the problems described in my question? Where do I look and what do I look for? Mar 15, 2014 at 22:04
  • If all else fails I am going to try a different flavour of Linux, but, still struggled on -- no good, leading to another question I have asked here: "Linux Fedora 20: how to I deal with "import read failed (2)"? Mar 17, 2014 at 16:55

2 Answers 2


try it:

This will unlock pkcon (packagekit) and yum, also will clean all metadata from all repositories. If you have concerns with your internet connection should provide all information about how you are connected to internet, ethernet? wifi?. What network or wifi card do you have?

pkill -SIGKILL -u root -o yum
pkill -SIGKILL -u root -o pkcon
yum clean all
yum -y update && yum -y install emacs
  • Thanks avidva. I tried that. Sorry, but it didn't resolve the problem, a long output, then "Cannot retrieve metalink for repository: fedora/20/i386. Please verify its path and try again". I searched for this on the Web, and found it to be a very common fault. I did try a couple of the suggested remedies, but to no avail. see edit to question. Mar 16, 2014 at 14:28

At last, after almost six weeks of frustration, and numerous attempted solutions based on suggestions by kind friends and Internet question sites, I have solved the problem (I think -- I am cautiously optimistic). The underlying symptom was that yum install emacs failed with a long list of errors,. Now it has finally worked, without hesitation. I don't know why, finding out is my next quest.

This is what I followed:


Answer by Stramash November 4, 2013 at 2:24 pm

Resolved this by adding nameserver above my router’s address in resolv.conf that was obtained by DHCP.

Not quite sure why it will not work with the automatic DHCP settings.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.