1

I just had this problem where suddenly I cannot ssh into my HP-UX itanium, but still can ping. Few hours before that, I was still able to so. I tried to force reboot (Pressing the power button). Then, I cannot ssh or ping to the server anymore. My only available option now is to use a serial monitor. After connecting through serial, I found out that all the command in normal shell are now unable to use. Have anyone ever tried debuging using a serial connection? I've googled for manual or guide but still can't find any.

Here is a detail of the server:

HP-UX itanium rx2800

HP serial monitor EM100

Edit: As I mentioned about the command that is unable to use, it is because I was in the EFI shell. I have addaed some picture. Maybe this can help to give more information. enter image description here enter image description here enter image description here enter image description here

EDIT: I've editted 2 more picture when the server first power on. There seems to be some error about the SCSI which is the hard disk. I would like to assume that the hard disk is the cause for this problem, but I'm not really sure. I've also tried to follow this link link, where I tried to reset the configuration back as default. The EFI Shell seems like it doesnt understand the command.

enter image description here enter image description here

5
  • By the way, this is the official HP-UX forum: h30499.www3.hp.com/t5/General/bd-p/itrc-17.
    – user17530
    Commented Mar 13, 2014 at 4:46
  • What do you mean by “all the command in normal shell are now unable to use”? Do they give errors or what? Commented Mar 13, 2014 at 23:31
  • @Gilles. Yes, when I tried su root. It returned Exit status code: Invalid parameter. When I tried ls. It returned Exit status code: No Mapping. Commented Mar 14, 2014 at 2:34
  • 2
    Ah, ok. It's clear now… I voted to reopen, but I'm not sure if we have expertise about HP's EFI bootloader. It's technically not about Unix but about HP's firmware. As this is rather off the beaten path for us, you're likely to have better luck on HP's specialized forum. Commented Mar 14, 2014 at 2:38
  • Thank you. I have posted in the hpux forum too. Just trying my luck in here. Maybe there's someone who have experience using EFI bootloader. Commented Mar 14, 2014 at 3:01

1 Answer 1

1

An old question, but for the sake of completeness:

Unfortunately, this is exactly what a boot attempt on a HP-UX Itanium system with a failed system disk looks like.

When entering the EFI shell, it displays a device mapping table. It lists all disk devices detected and usable by the firmware. In this case, it lists only one line:

blk0 : Acpi(HWP0002,0)/Pci(2|0)/Ata(Primary,Master)

The only ATA (= the old name for IDE) disk device on any Itanium systems is the CD-ROM/DVD drive on the system. The fact that there are no hard disks listed indicates that your system disk has failed.

Since it looks like the system disk was not mirrored (or if it was, the mirror has also failed), the only hope would be to replace the failed disk and then restore the system from backup. Fortunately, HP-UX has a pretty good system disk backup utility called Ignite-UX. If you happen to have an existing full Ignite-UX backup from the system disk, it would be possible to boot from the backup media (with HP-UX, usually a DAT/DDS tape) and basically "Select OK and press Enter to restore the system".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .