1

This question could arguably be posted on both networking.stackexchange and unix.stackexchange. I'll start here.

I have a freeBSD (pfsense 2.1) server running as a router on google fiber.

In order to get above 10 Mbps I need to enable egress filtering on the wan port
(aka 802.1p, traffic priority, Class of Service, CoS, vlan pcp ).

Running ifconfig, I can see that the vlanpcp is set to 0.

How do I change the vlanpcp from 0 to 3 ?

ifconfig
...
re0_vlan2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=3<RXCSUM,TXCSUM>
    ether 00:1c:c0:d5:e0:e2
    inet 23.255.241.45 netmask 0xfffff800 broadcast 23.255.247.255
    inet6 fe80::21c:c0ff:fed5:e0e2%re0_vlan2 prefixlen 64 scopeid 0x8
    nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    vlan: 2 vlanpcp: 0 parent interface: re0

It looks link on linux this can be done with vconfig, however freebsd doesn't use vconfig.

For reference, I am using these instructions for setting up the vlans.

https://www.dropbox.com/s/zg9ju9373t0fnpu/GoogleFiberRouterGuide.pdf

https://productforums.google.com/forum/#!topic/fiber/AbNh8ij72Mw

2

FreeBSD is not like Linux. This is particularly true regarding network configuration: "everything" is in ifconfig. A simple man ifconfig will confirm you that.

So to change the value of vlanpcp for you re0_vlan2:

ifconfig re0_vlan2 vlanpcp 3

More to read:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.