My distro is fedora 17 Gnome -64, and the wireless adapter is Edimax EW-7612UAn V2. I never used wireless on this computer and it is not so long ago I installed this op system. I installed wireless on another computer with fedora 17 few years ago, but I don't remember how to set it up.

There is no wireless showing up anywhere, and I couldn't set it up with network connection because it didn't see the adapter, I think.

This is what I've done:

I've built the wpa_supplicant, had one error, but fixed it. The driver won't build I think, the only directions where to build and make wpa_supplicant, but now I found that there is a driver folder to with a makefile, can't build that one, says that a folder is missing. This is from the file on their website to build. But there is no wireless. I've done everything in the readme file from the vendor. But no wireless showing up?

sudo lshw -c network -sanitize
   description: Ethernet interface
   product: 82573E Gigabit Ethernet Controller (Copper)
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: p1p1
   version: 03
   serial: [REMOVED]
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.2.14-k duplex=full firmware=1.0-7 ip=[REMOVED] latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:42 memory:d0080000-d009ffff memory:d0000000-d007ffff ioport:4000(size=32)

After I took the extension cord "off" the adapter, the system could see it:

   description: Wireless interface
   physical id: 1
   bus info: usb@3:1
   logical name: wlan0
   serial: [REMOVED]
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192cu driverversion=3.9.10-100.fc17.x86_64 firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

But it says that the hardware is disabled? In the network manager

  • Do you have a newer version of Fedora? F17 is past its end of life. If you can't upgrade LMK and I'll see if I can help you out.
    – slm
    Mar 12 '14 at 0:42
  • Whats LMK? I like fedora 17 best. I have it on two computers. Had something to do with gnome/user interface of F18. Mar 12 '14 at 0:54
  • Fair enough, just thought I'd ask. Sorry short for "Let Me Know".
    – slm
    Mar 12 '14 at 1:14
  • Emphasizing what slm said: Since F17 is past its end-of-life, it no longer receives any sort of updates, including security updates. So if for example someone was to discover a critical SSL vulnerability, you're not going to get fixes. F20 is the current release, and F21 is coming Real Soon Now.
    – larsks
    Mar 12 '14 at 1:58
  • Ok I'll soon setup some more computers, I'll probably update fedora then. Mar 12 '14 at 9:15

As I suggested in this similar Q&A titled: No wired ethernet connection, you want to start at the bottom of the stack when debugging networking issues. Use the following command to confirm that your WiFi NIC has a driver associated with it.

$ sudo lshw -c network -sanitize
       description: Wireless interface
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: [REMOVED]
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.12.11-201.fc19.x86_64 firmware= build 35138 ip=[REMOVED] latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:44 memory:f2400000-f2401fff

Pay special attention to the configuration: line, looking for the portion that shows driver=....

  • sudo lshw -c network -sanitize sudo: lshw: command not found sudo lshw -c network -sanitize sudo: lshw: command not found sudo lshw -c network -sanitize *-network sudo: lshw: command not found Mar 12 '14 at 4:21
  • I tried this command Mar 12 '14 at 4:22
  • @somethingSomething - you may have to install lshw. sudo yum install lshw.
    – slm
    Mar 12 '14 at 4:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.