2

I just bought a new laptop, a Lenovo IdeaPad U330 touch, and after some struggle (with the Secure Boot stupidity) I have managed to install Arch Linux. I have configured my system, installed all the drivers (I think), but I have a problem with my wireless disconnecting from the network.

I have noticed that my dmesg is being spammed with the

ideapad_laptop: Unknown event: 1

Also, somewhere in the flood of all those messages, there appears

mce: [Hardware Error]: Machine check events logged

but searching for the latter, there was a known bug and it's supposed to be fixed in the 3.14 version of the kernel.

I don't know if those messages are related to my wireless issues but I thought they might be relevant. I'm pasting the last few lines of dmesg with wireless reconnecting:

[ 2513.577794] ideapad_laptop: Unknown event: 1
[ 2534.762183] ideapad_laptop: Unknown event: 1
[ 2555.958244] ideapad_laptop: Unknown event: 1
[ 2577.159613] ideapad_laptop: Unknown event: 1
[ 2580.083918] cfg80211: Calling CRDA to update world regulatory domain
[ 2580.918208] wlp2s0: authenticate with 10:fe:ed:65:58:c0
[ 2580.920015] wlp2s0: send auth to 10:fe:ed:65:58:c0 (try 1/3)
[ 2580.924404] wlp2s0: authenticated
[ 2580.931245] wlp2s0: associate with 10:fe:ed:65:58:c0 (try 1/3)
[ 2580.957371] wlp2s0: RX AssocResp from 10:fe:ed:65:58:c0 (capab=0x431 status=0 aid=10)
[ 2580.968632] wlp2s0: associated
[ 2598.361115] ideapad_laptop: Unknown event: 1
[ 2619.550989] ideapad_laptop: Unknown event: 1
[ 2621.534185] cfg80211: Calling CRDA to update world regulatory domain
[ 2622.369409] wlp2s0: authenticate with 10:fe:ed:65:58:c0
[ 2622.371192] wlp2s0: send auth to 10:fe:ed:65:58:c0 (try 1/3)
[ 2622.375724] wlp2s0: authenticated
[ 2622.378073] wlp2s0: associate with 10:fe:ed:65:58:c0 (try 1/3)
[ 2622.426904] wlp2s0: RX AssocResp from 10:fe:ed:65:58:c0 (capab=0x431 status=0 aid=10)
[ 2622.428139] wlp2s0: associated
[ 2624.830025] cfg80211: Calling CRDA to update world regulatory domain
[ 2625.652178] wlp2s0: authenticate with 10:fe:ed:65:58:c0
[ 2625.653835] wlp2s0: send auth to 10:fe:ed:65:58:c0 (try 1/3)
[ 2625.679633] wlp2s0: authenticated
[ 2625.680707] wlp2s0: associate with 10:fe:ed:65:58:c0 (try 1/3)
[ 2625.800834] wlp2s0: associate with 10:fe:ed:65:58:c0 (try 2/3)
[ 2625.858120] wlp2s0: RX AssocResp from 10:fe:ed:65:58:c0 (capab=0x431 status=0 aid=10)
[ 2625.874661] wlp2s0: associated
[ 2640.757569] ideapad_laptop: Unknown event: 1
[ 2661.948093] ideapad_laptop: Unknown event: 1
[ 2683.154343] ideapad_laptop: Unknown event: 1
[ 2704.340696] ideapad_laptop: Unknown event: 1

Here is also the output of iwconfig:

wlp2s0    IEEE 802.11bgn  ESSID:"Krizred2"  
      Mode:Managed  Frequency:2.427 GHz  Access Point: 10:FE:ED:65:58:C0   
      Bit Rate=90 Mb/s   Tx-Power=16 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=54/70  Signal level=-56 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:380  Invalid misc:627   Missed beacon:0

lo        no wireless extensions.

and lspci | grep Net:

02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

Kernel: Linux 3.13.6-1-ARCH

EDIT

Just now I noticed this, while trying to update my system, just in case, since I don't have much to lose. I tried to update my system with providing network connection with USB tethering over my mobile phone.

There I noticed that my phone gets disconnecting in a similar way than my wifi! Even with USB tethering turned off. I also tried with an USB flash key, but that seems to be working.

19
  • 1
    So your question is basically about the wireless right? Could you add the output of iwconfig and lspci | grep Net?
    – terdon
    Mar 10, 2014 at 22:03
  • I REALLY hope this is the only problem...anyway, I'we edited my question
    – Alko
    Mar 10, 2014 at 22:12
  • Thanks. I don't know if it's the only one, but on the stack exchange sites, you should limit yourself to one post per question which is why I asked which one you really care about. For what it's worth I've seen similar messages on my Dell and they had something to do with the "special" buttons.
    – terdon
    Mar 10, 2014 at 22:15
  • Yes, I also read something about fn keys doing this, but it kinda confuses me...sorry, I hope my question isn't to broad I asked if these two can be somehow related...
    – Alko
    Mar 10, 2014 at 22:18
  • No, mentioning it is useful, as you said, you never know. My comment was to make sure that the actual problem you want to solve is not the spamming of dmesg but the reconnecting wireless.
    – terdon
    Mar 10, 2014 at 22:22

2 Answers 2

0

You require to compile your own custom-kernel from the Vanilla tree to acquire that patch.

Arch Linux First-Time Custom Kernel Guide

The issue with distribution-kernels is that you do not receive the benefit of the bleeding-edge tree available on Kernel.org.

The most daunting task here is to set your Kernel Flags. You also require a compiler toolchain (GCC). Your distribution, Arch, should have packages available to install for developers. When you meet that prerequisite, you will want to compile for your system.

If you have any questions about which flags you are requiring to enable, refer to the database at LKDB:

Linux Kernel Driver Database

You need to discover what hardware in your system is supported by which kernel drivers.

0

If your phone also shows the same symptoms, it is a very strong indication that your WiFi setup is flaky, and your machine (and phone) are probably fine.

Go to the nearest WiFi hotspot (Starbucks works fine ;-) and try there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .