1

I am trying to install libvirt from source codes, my workflow is shown below,

#!/bin/sh
apt-get install gnutls-bin libgnutls-dev -y
apt-get install libxml++2.6-2  libxml++2.6-dev -y
apt-get install libdevmapper-dev -y
apt-get install libpciaccess-dev -y
apt-get install python-dev -y
apt-get install libnl-dev -y

if [ ! -f ./libvirt-1.1.1 ]; then
wget http://libvirt.org/sources/libvirt-1.1.1.tar.gz
fi

tar -xzvf ./libvirt-1.1.1.tar.gz
cd ./libvirt-1.1.1
./configure --prefix=/usr --localstatedir=/var  --sysconfdir=/etc
make
make install

I have no trouble in configure, make, and make install. However, after make install finishing, when I type virsh --version, I get the following error message:

virsh: /usr/lib/libvirt.so.0: version `LIBVIRT_PRIVATE_1.1.1' not found (required by virsh)

I wonder what's wrong with that? Please help, thanks!

1

1,use apt-get remove --purge libvirt0 and apt-get remove --purge libvirt-bin to remove libvirt.

2,find anything remained concernning on "libvirt", like

find / -name "libvirt"

3,delete all of them(except for something in /sys) may work around this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.