3

Running "sudo apt-get update" results in:

W: Failed to fetch gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_saucy-security_universe_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_saucy_universe_binary-amd64_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_saucy_main_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_saucy_universe_binary-i386_Packages Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

I have tried to run:

sudo rm -R /var/lib/apt/lists/partial/*

sudo rm -fR /var/lib/apt/lists/*

sudo apt-get clean

I have also tried the Fix MergeList problems button of the Software Sources tool. I am running Linux Mint 16 Cinnamon 64 bits.

In the Update Manager I can see many updates that I should install but attempting to install them results in:

E: Unable to parse package file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_universe_i18n_Translation-en (1) E: Problem opening /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-amd64_Packages E: The package lists or status file could not be parsed or opened. E: _cache->open() failed, please report.

Any ideas?

1

2 Answers 2

3

Those messages are normally due to failures during the download of the list or a glitch in the mirror. You can fix it by removing the faulty lists:

$ sudo rm /var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_saucy_universe_binary-amd64_Package

and updating with sudo apt-get update. If it still happens use another mirror or wait for a bit first.

2
  • Running the command actually helped for a little while, but after a few days, the problem is back. Changing mirror did not help.
    – user254173
    Mar 16, 2014 at 13:42
  • @user254173 is a problem with the servers or your internet connection, not something you can "fix" localy.
    – Braiam
    Mar 16, 2014 at 13:46
1

I may assume after you've been removing the files in /var/lib/apt/... you did a new apt-get update?

You could also try

apt-get check -m -f

and verify the /etc/apt/sources.list to be valid by visiting each repository's address in your browser, it should give a file listing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .