I tried installing Nvidia drivers using different ways: repository nvidia-current, nvidia-331 and using downloaded file from Nvidia web site. Installations seems to be successful, although I got pre-installation script failed message from .run file.

After installation I ran sudo nvidia-xconfig and reboot.

In both cases the system doesn't seem to use installed driver. Going to nvidia-settings gives an error:

You do not appear to be using NVIDIA X driver. Please edit you X configuration file (just run nvidia-xconfig as root), and restart the X server.

Running nvidia-smi give an error:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

lsmod command lists nvidia among other modules:

nvidia 10688804 0

So, I'm totally confused. How can I change that OS is using nvidia driver. How to get rid of error above?


My nvidia-settings opens now, but it has not much settings inside: enter image description here

In the command line I see the following error:

** (nvidia-settings:4334): WARNING **: PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory)

** Message: PRIME: is it supported? no

The command inxi -Gx (whatever it does) gives me:

Graphics: Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 X.Org: 1.14.3 drivers: nouveau,intel (unloaded: nvidia,fbdev,vesa) Resolution: 1920x1080@60.0hz GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

So I can conclude that nvidia driver is not used. How to fix it?

migrated from askubuntu.com Mar 9 '14 at 9:55

This question came from our site for Ubuntu users and developers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.