2

I tried installing the Nvidia drivers for my GeForce GTX 760M in various ways:

  • using the official repository:

    • package nvidia-current
    • package nvidia-331
  • downloading an installation file from the Nvidia web site


Even though the installation seemed to be successful, I got pre-installation script failed message from .run file (the directly downloaded installation file).

After installation, I ran sudo nvidia-xconfig and rebooted.


In both cases, the system doesn't seem to use the installed driver. Going to nvidia-settings gives an error:

You do not appear to be using NVIDIA X driver. Please edit you X configuration file (just run nvidia-xconfig as root), and restart the X server.


Running nvidia-smi gives an error:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

lsmod command lists nvidia among other modules:

nvidia 10688804 0

So, I'm totally confused. How can I change that OS is using Nvidia driver? How to get rid of the error above?


UPDATE

My nvidia-settings opens now, but it has not many settings inside:

empty nvidia-settings

In the command line I see the following error:

** (nvidia-settings:4334): WARNING **: PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory)

** Message: PRIME: is it supported? no

The command inxi -Gx (whatever it does) gives me:

Graphics: Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 X.Org: 1.14.3 drivers: nouveau,intel (unloaded: nvidia,fbdev,vesa) Resolution: 1920x1080@60.0hz GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A

So I can conclude that the Nvidia driver is not used. How to fix it?

0

Here is a suggestion for installing OpenSUSE Tumbleweed (as of April 2019) on a recent PC (Asus G20) with both Intel & nVidia (GTX970) graphics controllers:

  • in the BIOS settings, BOOT parameters, you can continue to use UEFI mode, but change the OS from "Windows" to "Other OS"

  • if your installation of OpenSUSE crashes, hangs, or fails with an unexpected error, try adding these options to the kernel boot line (press 'e' in the Grub boot screen): textmode=1 nomodeset acpi=off splash=verbose

  • you may need to do this each time when you run the 'Installation' or 'Update' option

  • after installing on an Asus G20, the following kernel options are recommended permanently, which you can set in Yast, Boot, Kernel parameters: pci=acpi pci=noaer splash=silent

  • also, it is suggested to install a minimum system in the non-graphics mode first, just to get the system running, then download the nVidia drivers for X using Yast from the Nvidia OpenSUSE repo, which is described here: https://en.opensuse.org/SDB:NVIDIA_drivers

  • install the appropriate for your graphics card. I used for a GTX970:

  • the 'x11-video-nvidiaG05' driver, then 'nvidia-glG05' for OpenGL 3D acceleration

  • then run 'Update' to bring the system up to graphics mode

This problem was submitted to OpenSUSE.

Possible causes: - PCI Advaced Error Reporting (AER) floods the system log - possible conflicts between the Intel and nVidia controllers prior to nVidia drivers being installed cause crash

[end]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.