If a directory contains an album encoded as one large .wv file and a .cue file, splitting the entire album into individual .flac tracks is a simple task:

$ cuebreakpoints foo.cue | shnsplit -o flac foo.wv

What I'd like to know is how to split a file where the names don't match up, e.g.: 'foobar.wv' and 'foo.cue'. If I attempt this I get this error message:

shnsplit: warning: none of the builtin format modules handle input file: [foobar.wv]
shnsplit: error: cannot continue due to error(s) shown above

Do I need to alter the .cue file? Because simply renaming 'foobar.wv' to 'foo.wv' prior to splitting doesn't seem to work for me. Or is there something wrong with the wavpack package?

PS: I didn't know how to tag this question properly. Sorry 'bout that.

Some more info

To be clear, I should point out that the text inside the .cue files points to the appropriate .wv files.

Yet more info

I'm having a bit of luck, for whatever reason, by decompressing the .wv to .wav and then altering the .cue file accordingly.

Not ideal but it's working so far.

3 Answers 3


Make sure that the FILE line in the cue file points to the correct name. In your case it should read:

FILE "foobar.wv" WAVE

Then renaming foo.cue to foobar.cue should do the trick.

Another option is to recreate the cue sheet from the original wv file (provided the info is there):

$ wvunpack -c foobar.wv > foobar.cue

then split as usual.


The .cue file has a section within it, FILE that points to the wavpack file, .wv:

$ grep FILE cdimage.wv.cue
FILE "cdimage.wv" WAVE

Incidentally, you can do all this directly with just shnsplit. This CLI is part of the package shntools on Debian/Ubuntu.

$ shnsplit -f cdimage.wv.cue -o flac -t '%n - %p - %t' cdimage.wv

This will produce files with the track number (%n), artist's name (%p), & track name (%t).

From man shnsplit:

      -t fmt Name  output files in user‐specified format based on CUE 
         sheet fields.  The following format‐ting strings are recognized:

              %p     Performer
              %a     Album
              %t     Track title
              %n     Track number



Maybe you don't have wavpack installed. So try installing that first, then go:

$ cuebreakpoints foo.cue | shnsplit -o flac foo.wv

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .