2

If I am in a Linux virtual terminal (pressing Control-Alt-F1 on Ubuntu), and I use the command cacafire, I get the flames inside the actual terminal.

However, if I am in the gnome environment, and I start a terminal and run cacafire, I get a separate window popping up that displays the fire.

How can I force it to display the fire in the same terminal that it is run from?

2 Answers 2

3

It's man doesn't seem to have a option to control it. But you can use DISPLAY= cacafire and cacafire wouldn't know how to connect to your X server; then fallback to running in the current terminal.

2
  • This works for aafire, but for cacafire, it says "Failed to initialize libcaca"
    – merlin2011
    Mar 8, 2014 at 18:41
  • @merlin2011 That sounds like a bug, but it does indeed work. asciinema.org/a/8070
    – llua
    Mar 8, 2014 at 20:25
0

Make sure the environment variable DISPLAY has no value, for example run DISPLAY= cacafire

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .