I'm trying to install Linux Mint 16, 64-bit, MATE using a live USB. The boot option menu itself is responsive and work as expected. However, when I execute any of said boot options, the system freezes. The same thing occurs when installing Ubuntu. Fedora 20 and Debian 7.4.0 both install successfully

If I mount the image onto the USB using, specifically, YUMI - Multiboot USB Creator the system manages to print a few lines of text. The text is visible in one of the images found in the link below.

Imgur album of my screen after the problem has occured.

Already tried

  1. Mounting the image onto the USB drive (FAT32) using unetbootin, LinuxLive USB Creator and YUMI - Multiboot USB Creator.
  2. Attempting to install the OS both before and after writing zeros to the entire SSD using the built-in "Erase Disk" feature of PartedMagic.
  3. Trying to install the OS while the Live USB is plugged into each of the available USB 2.0 and 3.0 ports.
  4. Testing the process, but with only one RAM stick installed.
  5. Allowing it to be frozen for up to approximately 5 hours. It didn't seem to change anything.
  6. Tested the same USB, image and mounting configurations on two other, Intel-based, computers. It worked correctly both times.
  7. Pressing TAB (unetbootin and YUMI - Multiboot USB Creator) and appending the following to the editable field:

    noapic nolapic acpi=off


From the information I've gathered various boards found via Google, my motherboard's integrated NIC is infamous for not being natively supported by any of the major Linux distributions. Perhaps the installation process is halted upon not being able to detect any working NIC(s). Debian, for instance, doesn't natively support my integrated NIC, Atheros AR8171, thus I experienced issues during its installation.

My APU, the integrated one of the 7850K CPU, seems to cause many Linux users issues due to incompatible drivers. The screen resolution appears to change right before the system freezes. The last few lines printed by the YUMI - Multiboot USB Creator before the system freezes include the word "radeon". I believe these two facts reinforces the idea that there's some form of issue related to the APU.

Internal Hardware

  • CPU: AMD A10-7850K (Kaveri) @ 3.7 GHz (Factory settings)
  • Motherboard: ASRock FM2A88X-ITX+ FM2 (Factory settings)
  • NIC: Qualcomm Atheros AR8171 (Integrated)
  • GPU: AMD Radeon R7 Series (Integrated)
  • RAM: Corsair Vengeance 2x4GB DDR3 1600MHz CL9 (CMZ8GX3M2A1600C9)
  • SSD: Corsair Force LS SSD 60 GB
  • HDD: 1TB Seagate Barracuda® SV35, SATA 6Gb/s, 7200rpm, 64MB
  • DVD/CD Reader: None
  • What tool did you use to create the USB? If unetbootin, try multusystem. – terdon Mar 8 '14 at 3:16
  • I'm using Windows to mount the image onto the USB. Thus I tested with the related YUMI - Multiboot USB Creator instead. I've updated the question accordingly. – Pontus C Mar 8 '14 at 10:10
  • Another possible problem would be your graphics card model. What do you have? You should also try editing the grub options, just in case. Hit e in the options screen and try adding noapic nolapic acpi=off to the kernel's options. – terdon Mar 8 '14 at 16:51
  • I'm using the integrated APU/GPU of my CPU. I tested your string but the result stayed the same. – Pontus C Mar 8 '14 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.