1

After a:

yum install -y flash-plugin

and a

USERNAME="USERNAMEHERE"; mkdir -p "/home/$USERNAME/.firefox/plugins"; ln -s "/usr/lib64/flash-plugin/libflashplayer.so" "/home/$USERNAME/.firefox/plugins"

I could always install flash player for Scientific Linux. But now, after a fresh install of Scientific Linux 6.5.. I do the same, but in the about:plugins there isn't any...

My queston: Why? What am I missing?

UPDATE: yes, the Firefox is 64 bit too: it's from:

https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-x86_64/en-US/
  • Is version of firefox also 64bit? – UVV Mar 7 '14 at 22:29
1

I finally found it out in the weekend, the main solution was to put the libflashplayer.so to the good directory.. and the directory was: "/usr/lib/mozilla/plugins" ... so not the firefox/plubins..

a little bit further on installing Firefox correctly:

# I used it after: 
yum --releasever=6.5 update
# use BleachBit regularly!

#############################################
# 1) cd to home dir
cd

#############################################
# 2) download firefox
lynx -dump https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-x86_64/en-US/ | awk '/.tar.bz2/ && /https/ {print $2}' | xargs -I {} wget {} -O firefox.tar.bz2

#############################################
# 3) extract it, if there was an old one, rename it..
mv .firefox .firefox-OLD-`date +%F`; mv .mozilla .mozilla-OLD-`date +%F`; tar -xjf firefox.tar.bz2; mv "firefox" ".firefox"; rm firefox.tar.bz2

#############################################
# 4) install rpmforge to get flash in the repositories + install flash
# ONLY THESE LINES NEEDED TO BE RUN BY ROOT
yum install -y rpmforge-release; ln -s "/usr/lib64/flash-plugin/libflashplayer.so" "/usr/lib/mozilla/plugins"

#############################################
# 5) configure firefox (BY HAND)
# main: home page, download place
# tabs: no warnings
# applications: always ask ALL
# privacy: don't track, don't remember history, delete all history, don't suggest anything
# advanced: NO auto/smooth scrolling, NO spell checking, DON'T check if browser is default, DON'T let any statistics to send, etc. certificates: tick in OCSP as mandatory

# Add-ons
https://addons.mozilla.org/en-US/firefox/addon/wot-safe-browsing-tool
https://addons.mozilla.org/en-US/firefox/addon/adblock-plus
https://www.eff.org/https-everywhere
https://addons.mozilla.org/en-US/firefox/addon/google-ssl-243978

extras: 
https://addons.mozilla.org/en-US/firefox/addon/ghostery
https://addons.mozilla.org/en-US/firefox/addon/cookie-whitelist-with-buttons
https://addons.mozilla.org/en-US/firefox/addon/noscript
https://addons.mozilla.org/en-US/firefox/addon/requestpolicy

#############################################
# 6) 
about:config

app.update.silent
true

network.dns.disableIPv6
true

browser.download.manager.scanWhenDone
false

browser.sessionstore.max_tabs_undo
1

browser.sessionstore.max_windows_undo
1

geo.enabled
false

network.http.sendRefererHeader
0

pdfjs.disabled
true

noscript.showPermanent
false

plugin.state.flash
1

# useragent: 
New -> String
general.useragent.override
Mozilla/5.0 (X11; x86_64; rv:27.0) Gecko/20100101 Firefox/27.0

#############################################
7) disable flash cookies. Go to
https://www.youtube.com/
right click a flash element
Right click -> Global Settings... -> Storage TAB -> Block all sites from storing information on this computer
Camera and Mic TAB -> Block all sites from using the camera and microphone
Playback -> Block all sites from using peer-assisted networking

#############################################

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.