I used to use TigerVNC to connect to a Mac MINI running Mountain Lion from my laptop running Fedora Core 18. After upgrading the Mac to Maverick, I now get the error "No Matching Security Types"

I've tried every setting I can change through the GUI with the same result. I have also tried using other free VNC viewers, and still have had no luck.

I know for a fact that Screen Sharing is working, I am able to connect using another Mac.

Is there a way to do this without having to purchase a VNC viewer like RealVNC that I don't know will work?

The other viewers I tried are:

  • remmina (only appears to have SSH or SFTP as protocol options)
  • NoMachine (only has SSH and NX as options)
  • I downloaded gtkvncviewer but it doesn't appear to actually do anything and give no error report

Vinagre appears to work well enough.


You invoke it from the command line like so:

$ vinagre

There is also a applet that should be available when you install it so that you can just pick machines that you've bookmarked with it form a pulldown when you add the applet to your toolbar.

  • 1
    I had problems getting vinagre to work with a password length of over 8 characters. – Roger Filmyer Sep 11 '14 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.