1

I've downgraded systemd to version 208. Although I still have /etc/udev/rules.d/80-net-setup-link.rules on my disk, but the names of network interfaces were not named correctly:

e.g wlp3s0 is not renamed to wlan0, and so is enp0s25 to eth0

Any ideas? I want the names back to wlan0 and eth0

P.S I'm running Arch Linux, I marked systemd and a few other package for upgrade

warning: systemd: ignoring package upgrade (208-11 => 210-2)
7
  • Are you trying to get the names back to wlan0 and eth0? Those are being phased out.
    – slm
    Mar 5, 2014 at 16:32
  • @slm Yes I'm trying to get the names back
    – daisy
    Mar 5, 2014 at 16:32
  • Are you just doing this temporarily or are you planning on doing this going forward?
    – slm
    Mar 5, 2014 at 16:35
  • @slm I want this persistent. Or are you talking about the downgrade of systemd?
    – daisy
    Mar 5, 2014 at 16:36
  • Sorry, are you planning on manually maintaining wlan0, eth0 going forward w/ every update?
    – slm
    Mar 5, 2014 at 16:37

2 Answers 2

2

You use a udev rule to enable the device names that you want: see the Arch wiki entry.

Essentially, create a rule in /etc/udev/rules.d/10-network-name.rules like:

SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="5aa:bb:cc:dd:ee:ff", NAME="ether"
SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="gg:hh:ii:jj:kk", NAME="wifi"

Note the warning about not using ethx or wlanx as names to avoid race conditions.

1

You need to use 80-net-name-slot.rules instead of 80-net-setup-link.rules for the filename in release v197 through v208. This is documented here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .