Here's the set-up:

  • 2x identical GTX460 cards
  • 1x BenQ 144hz monitor (1920x1080)
  • 1x Asus 60hz monitor (1920x1080)

I was told to avoid installing the NVIDIA driver myself and use the ppa:xorg-edgers/ppa repository instead. I have tried it both ways with little success, which is to say, either method works perfectly until I visit nvidia-settings and enable the second monitor, at which point cinnamon crashes.

It will crash perpetually if attempted to restart and keep you in the fallback mode.

Using XFCE instead of Cinnamon doesn't seem to have this problem but I'm resolved to figure out what's going on.

Here's some relevant outputs:

Working xorg.conf

Crashing xorg.conf

Here's the output from /var/log/Xorg.0.log

And here is output from /home/username/.xsession-errors - it has some peculiar stuff about cinnamon breaking but I can't make sense of it.

inxi -Fxz (before NVIDIA drivers)

System:    Host: minty-pc Kernel: 3.11.0-12-generic x86_64 (64 bit, gcc: 4.8.1) Desktop: Gnome Distro: Linux Mint 16 Petra Machine:   Mobo: Gigabyte model: Z68A-D3H-B3 Bios: Award version: F11 date: 10/12/2011 CPU:       Quad core Intel Core i7-2600K CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27138.4 
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz Graphics:  Card-1: NVIDIA GF104 [GeForce GTX 460] bus-ID: 01:00.0 
           Card-2: NVIDIA GF104 [GeForce GTX 460] bus-ID: 02:00.0 
           X.Org: 1.14.3 drivers: (unloaded: fbdev,vesa) FAILED: intel,nouveau Resolution: [email protected], [email protected] 
           GLX Renderer: Gallium 0.4 on NVC4 GLX Version: 3.0 Mesa 9.2.1 Direct Rendering: Yes Audio:     Card-1: 2x NVIDIA GF104 High Definition Audio Controller driver: snd_hda_intelsnd_hda_intel bus-ID: 02:00.1
           Card-2: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: ce00 bus-ID: 04:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Belkin F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU] driver: r8712u usb-ID: 050d:945a
           IF: wlan0 state: down mac: <filter> Drives:    HDD Total Size: 624.2GB (0.9% used) 1: id: /dev/sda model: OCZ size: 60.0GB 
           2: id: /dev/sdb model: OCZ size: 60.0GB 3: USB id: /dev/sdc model: Cruzer size: 4.0GB 
           4: id: /dev/sdd model: WDC_WD5000BPVT size: 500.1GB  Partition: ID: / size: 46G used: 3.9G (9%) fs: ext4 ID: swap-1 size:
7.67GB used: 0.00GB (0%) fs: swap  RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present Sensors:   System Temperatures: cpu: 34.0C mobo: N/A gpu: 45.0,40.0 
           Fan Speeds (in rpm): cpu: N/A  Info:      Processes: 200 Uptime: 25 min Memory: 776.6/5886.1MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4

Here's what happens when I try to restart Cinnamon via cinnamon --replace:

~ $ cinnamon --replace
      JS LOG: About to start Cinnamon
      JS LOG: Cinnamon started at Sat Mar 01 2014 15:04:22 GMT-0700 (MST)
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
Window manager warning: Log level 6: The program 'cinnamon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 4423 error_code 8 request_code 7 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap

I suppose I should mention the cards are connected with a SLI bridge. I've tried switching slots the monitors were plugged in to.


I've installed the unlisted 334.21 driver from the NVIDIA site manually (amended blocklist, purged nvidia*, ran update-initramfs -u, ran driver install while in recovery mode - perhaps this is insufficient to remove all of nouveau's stuff?) and here is the latest attempt to start cinnamon:

vladdy@minty-pc ~ $ cinnamon --replace
Xlib:  extension "RANDR" missing on display ":0".
Xlib:  extension "RANDR" missing on display ":0".
Segmentation fault
  • I noticed that both your screens seem to be called DFP-0 in the Xorg.log, I wonder if that is causing problems. I also suggest you post this on the mint forums since Clem, the developer, is quite active there.
    – terdon
    Mar 5, 2014 at 14:27
  • @terdon I [forums.linuxmint.com/viewtopic.php?f=49&t=161061](did post on the mint forums) - didn't get any response so I figured I'd have better luck here. I'll explore that, thanks for the tip
    – dsp_099
    Mar 5, 2014 at 22:11

1 Answer 1


Alright, well, I figured it out (sort of). I'll post the answer about the crash here in case someone googles this same issue.

I don't exactly know why Cinnamon is crashing, but I've read somewhere that you cannot have two X screens running at the same time due to some 3D-acceleration nonsense.

What this means is, both monitors are plugged into the same card now, and in nvidia-settings both screens are set to be X screen 0. (instead of X screen 0 and X screen 1) They're set to be absolutely positioned, with the second screen being offset by 1920.

So technically you have just one screen but it's routed to two monitors through one videocard.

I think it should be possible to keep them plugged into different cards while still having them set up this way, but I'm not inclined to test that and have to re-install again.

The crash wasn't caused by two monitors or two videocards - it was caused by NVIDIA driver trying to run two separate X instances or servers or whatever.

Humbly request nightmare be added to tags.

  • 1
    I didn't get one thing, did you manage to connect two monitors or you've just give up on that? Jun 30, 2014 at 16:57
  • 1
    Yes, I was able to do that. The key was to plug both of them in to one card and configure the nvidia settings (which really is a GUI for xscreenconfig or whatever, I forgot) such that you have ONE screen (keep in mind screen is not the same as a connected monitor)
    – dsp_099
    Jun 30, 2014 at 20:38
  • 1
    So you cannot use your 2nd card? And does Cinnamon also crash when you switch users (second user session is second X session)?
    – basic6
    Jun 10, 2015 at 19:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .