I'm trying to mount a samba host located at I can ping the host, I can open the share on Ubuntu and windows (with the credentials). When I try to manually connect:

pi@raspberrypi-web-server ~ $ smbclient -L
Enter pi's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

Sharename       Type      Comment
---------       ----      -------
IPC$            IPC       IPC Service (raspberrypi-media server)
Media Folder    Disk      Media Folder
print$          Disk      Printer Drivers
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

Server               Comment
---------            -------
RASPBERRYPI-MEDI     raspberrypi-media server

Workgroup            Master
---------            -------

I have this line in /etc/fstab:

// /mnt/smb cifs user=maikel,pass=PASSWORD,_netdev 0 0

But whenever I do:

sudo mount -a

I get the following error:

Retrying with upper case share name mount error(6): No such device or
address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Why doesn't my mount work? I've tried host raspberrypi-media but I got the same error?

2 Answers 2


Try this:

$ mount -t cifs -o user=maikel,pass=PASSWORD,_netdev \
    '// Folder' /mnt/smb

This should work. Also, try this to make sure you have permissions:

$ smbclient '\\\Media Folder' -U maikel

Type in your password and type in ls at the smbclient prompt.

  • 1
    The single quotes did the job. i used an \040 (space) in /etc/fstab and it works! Wow thanks! Mar 5, 2014 at 14:53

the trailing / on "//" was the original problem, by the way: share names do not end with a / and you had no share name in there.

You needed this:

// /mnt/smb cifs user=maikel,pass=PASSWORD,_netdev 0 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .