6

as mentioned above, I want to to completely turn off the console output, but putting console= or console=null in the kernel command line doesn't change a thing. When I enque quiet to the kernel command line it approximates this job, but I want to completely turn off the output.

So why is console=null not working, there isn't even an error message?

6

1. Using dmesg

One method would be to do so using dmesg:

   -n, --console-level level
          Set the level at which logging of messages is done to the console.  
          The level is a level number or abbreviation of the  level  name.
          For all supported levels see dmesg --help output.

For example:

$ sudo dmesg -n0

2. Using rsyslog

Another method would be through rsyslog. The config file /etc/rsyslog.conf:

#kern.*                                                 /dev/console

Changing this line to this:

kern.*                                                 /dev/null

NOTE: A restart of rsyslog is necessary, sudo service rsyslog restart.

3. Using sysctl

Lastly you can control this at the kernel level via sysctl.

I suggest you alter your /etc/sysctl.conf. Specifically, you want to tweak the kernel.printk line.

# Uncomment the following to stop low-level messages on console
kernel.printk = 3 4 1 3

You can see your current settings:

$ sudo sysctl -a|grep "kernel.printk\b"
kernel.printk = 4   4   1   7

4. Using silent

If you truly want to disable all logging, even during boot then change the string quiet to silent in the boot arguments to the kernel in GRUB, in /boot/grub2/grub.cfg.

linux   /vmlinuz-3.12.11-201.fc19.x86_64 ... rhgb silent ....
  • Thanks. Even when I put the log levels to 1 or 0 it doesn't lower the output. BTW I want to disable the output since startup, not only when the system is ready – user3085931 Mar 3 '14 at 14:20
  • the silent command didn't work either, I'll try the commenting of kernel.printk as you recommended tomorrow – user3085931 Mar 3 '14 at 14:53
1

After hours of searching:

Comment out the *.emerg line or change it to *.emerg /var/log/messages etc

  • 1
    Hi and welcome to the site. Please edit your answer and explain what file you are suggesting should be edited, and show both the original line and what you want to change it to. – terdon Dec 22 '14 at 10:19
  • Edited answer to make it more clear. – aseq Jun 14 '16 at 23:05
0

U-Boot is doing exactly what it should (silencing the output) with the following command:

#define CONFIG_EXTRA_ENV_SETTINGS \

        "silent=1\0" \

seems like this happens only on my system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.