3

I'm having an issue. I'm trying to install Gentoo in virtualbox. I can't use nano because when I press Ctrl + x, I see, I have written x letter. Something's wrong with Ctrl key in virtualbox. I've seen similar question, but the answer doesn't work to me. Any ideas?

5
  • Are you using the right Ctrl key or the left - I think the right one is automatically designated as the 'host' key
    – Wilf
    Commented Mar 2, 2014 at 22:56
  • @Wilf Left ctrl key. I know about 'host' key.
    – enedil
    Commented Mar 2, 2014 at 23:08
  • VirtualBox is rather buggy, but left+control has always worked for me. As one example of VB's buggyness, its host-only network adapter randomly just stops working in Windows. Closer to the OP, my right alt+letter combinations to get non-English accents like ñ sometimes, but not always, do not work in other Windows apps while I’m running VirtualBox.
    – samiam
    Commented Mar 3, 2014 at 9:28
  • Have you tried installing the VirtualBox addons? They always seem to solve mouse and keyboard related issues like these for me. Commented Jun 2, 2014 at 14:11
  • Already answered on SuperUser: Ctrl key doesn't work in Virtual Box, Linux host Commented Aug 16, 2016 at 17:12

1 Answer 1

7

After a LOT of research I found that it was a misconfiguration in my Gnome desktop settings of my host machine. I had a feature turned on which intercepted my control keys (left and right) and displayed a sort of animated bulls-eye on the cursor when either is pressed. The trouble with that accessibility feature is that it doesn't pass the control key on to any programs.

The solution was to turn it off.  To do so from Linux Mint 13 Maya (MATE) do the following:
1 - Click on the Menu button on the lower left corner of the screen.
2 - Click on Preferences
3 - Click on Assistive Technologies
4 - Click on Mouse Accessibility
5 - Click on the General tab
6 - Under Locate Pointer, uncheck the box that says "Show position of pointer when the Control key is pressed".

I'm attaching a screen shot with all those menus displayed, and the relevant check box circled in red. enter image description here

1
  • This worked for my Mint MATE 18.1 too
    – hanzo2001
    Commented Jan 23, 2018 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .