3

In Ubuntu 13.10 on my (Dual Core i5 Lenovo G570) laptop, I recently discovered the wonders of indicator-cpufreq, so I can extend my battery life dramatically by setting it to 'ondemand' or 'powersave' governor - here is the menu it shows:

                                                      indicator-cpufreq menu

I was wondering whether I could implement this in the other half other my dual boot on my laptop, Fedora 20. However, after looking at this documentation, and installing the kernel-tools package, when I run the command to list the available modes.

On Fedora I get:

wilf@whm1:~$ cpupower frequency-info --governors
analyzing CPU 0:
powersave performance

On Ubuntu I get:

wilf@whm2:~$ cpupower frequency-info --governors
analyzing CPU 0:
conservative ondemand userspace powersave performance

So can I get the conservative, ondemand, & userspace modes in Fedora?
Mainly the ondemand one


Fedora System Info

Kernel

Linux whm1 3.12.10-300.fc20.i686+PAE #1 SMP Thu Feb 6 22:31:13 UTC 2014 i686 i686 i386 GNU/Linux

Version
Fedora release 20 (Heisenbug)
Kernel 3.12.10-300.fc20.i686+PAE on an i686
/proc/cpuinfo, relevant /etc/default/grub (Fedora manages Grub, not Ubuntu):
#GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor pcie_aspm=force"
GRUB_CMDLINE_LINUX="vconsole.font=latarcyrheb-sun16 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rhgb quiet acpi_osi=Linux acpi_backlight=vendor pcie_aspm=force"

Ubuntu System Info

Kernel

Linux whm2 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:25:07 UTC 2014 i686 i686 i686 GNU/Linux

/proc/cpuinfo, relevant /etc/default/grub (I think is loaded by Fedora Grub):
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
  • The reason you do not see these governors is that the intel_pstate is activated by default i Fedora, as mentioned in the answer. This driver knows your CPU, and it may not be a good idea to disable it if you care about battry lifetime: unix.stackexchange.com/questions/121410/… – Rasmus Dec 13 '14 at 14:21
5

This is related to a new driver introduced in Fedora 20 that does not need more than those two governors. See this thread CPU Governors - where is ONDEMAND? for details.

To have the missing governors, you should boot with the kernel parameter intel_pstate=disable.

To do so, in the GRUB boot screen, choose "edit boot commandline" and add this to the line which starts with kernel. You can also add it permanently to the grub config file.

Note that normally you should not need others governors than those proposed by the new driver which does its job perfectly.

  • Thank You! It worked :D - added intel_pstate=disable to GRUB_CMDLINE_LINUX in /etc/default/grub, then ran grub2-mkconfig -o /boot/grub2/grub.cfg - also based on this post. Now have 1/2 hours extra battery life :) – Wilf Mar 2 '14 at 14:46
  • 1
    Nice find, I hadn't heard of this change – slm Mar 2 '14 at 15:36
  • 1
    Sorry for disturbing you, but when I get 90% CPU usage on 1 of my 4 threads, and all threads are running at 25% with Powersafe, I'm unhappy. And if I get 5% CPU usage on all of my 4 threads, and all threads are running at 100% with Performance, I'm unhappy as well. – yo' Mar 22 '14 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.