5

I'm trying to get the CLI password manager pass to work in my fish shell with auto completion. I've already found the necessary file, yet am having trouble finding out where to put it, or rather getting it to work. So far I've added it to:

  • ~/.config/fish/pass.fish
  • ~/.config/fish/completions/pass.fish
  • and added the content to my ~/.config/fish/config.fish file.

with no success.

3
  • Stupid question: have you closed and reopened your shell?
    – lgeorget
    Mar 2, 2014 at 13:06
  • Stupid questions are always appreciated: I rebooted my computer to be safe.
    – montauk
    Mar 2, 2014 at 13:18
  • FYI the location of that file is no longer valid; the new location seems to be git.zx2c4.com/password-store/tree/src/completion/…
    – nh2
    Nov 28, 2015 at 0:43

1 Answer 1

7

The second option listed (~/.config/fish/completions/pass.fish) is the preferred approach. The third should also work.

I tried the following:

  1. Put the file at ~/.config/fish/completions/pass.fish
  2. Type pass followed by a space
  3. Hit tab

And I see completions from that file.

It's possible that fish is looking somewhere else. Try echo $fish_complete_path and verify that it includes ~/.config/fish/completions/ . If it does not, you can put back the defaults by erasing it and starting a new session: set -e fish_complete_path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.